Mailinglist Archive: opensuse (1451 mails)

< Previous Next >
Re: [opensuse] 13.2 vs Leap vs Tumbleweed
07.02.2016 19:58, Dave Plater пишет:


On 07/02/2016 18:09, Andrei Borzenkov wrote:
07.02.2016 17:46, Michael Fischer пишет:
On Sun, Feb 07, Dave Plater wrote:
My only gripe is not being able to go to any runlevel besides 1 and 5.
Is that an effect of some bug, or a "design decision" to make runlevel 3
unavailable in some way?

When you finished with conspiracy theories you could explain what you
mean. I am just now running 13.2 VM in run level 3, so it is obviously
possible.
openSUSE:Leap:42.1 doesn't let you select any runlevel apart from
graphical user interface runlevel 5 or single user runlevel 1 aka s.
Init 3 leaves you at 5 and init 1 or init s takes you to 1. If you have

I just tested and I can both boot into run level 3 by simply adding `3'
to kernel parameters in bootloader and switch to run level 3 from
runlevel 5 by using "init 3". In the latter case it indeed does not
switch to tty with text mode login prompt, you need manually do Alt-F1.

Of course "systemctl set-default multi-user.target" and reboot is always
an option.

So you need to be more precise what exactly you do and how you try to
"select runlevel".

a problem with x on runlevel 5 you cannot kill the x sever and you can
only go to single user runlevel 1 with no network access.
I found this out when I tried to get my nVidia card working and plasma5
kept crashing. I gave up and removed the card, when I have a lot of
spare time on my hands and when I've worked out how to get runlevel 3
back again, I'll try again.
Dave P

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups