Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
[opensuse] chrome crashes kwin_x11 in plasma5 42.1
This has happened several times, but it does not always happen. If I use chrome (my preferred browser) to look at something in the course of my work, at some point suddenly kwin_x11 will crash and all my screen navigation in plasma5 will cease. The title bars disappear from all my open applications, and I am not able to switch desktops or navigate to a new application.

This is what I do when it crashes like this. I hit ctrl-esc to open the resources monitor. Using that, I stop chrome (which has like 5 or 6 processes associated it, but one click kills it all in the resources monitor).

On the resources monitor, the process for kwin_x11 says "stopped". I cannot kill it for some reason with the resources monitor.

So then I hit alt-f2 and type in konsole. I do a

> ps ax | grep kwin

and find the pid for kwin_xll. I have to kill it with

> kill -9 <pid>

as kill all by itself won't do it.

Then I hit alt-f2 again and type in kwin_x11 to restart it, and it restarts, and my desktop is back up and running, and I didn't have to exit out of all my applications.

So it works, but it is a pain in the neck, and basically chrome is unusable. Anyone have any ideas? I haven't filed a bug report yet, because I think there may be something wrong with my system to troubleshoot first.

--
George
Box #1: 42.1 | KDE Plasma 5 | AMD Phenom IIX4 | 64 | 32GB
Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups