Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] digikam crashes
On 01/24/2016 11:15 AM, don fisher wrote:
On 01/23/2016 06:53 PM, don fisher wrote:
On 01/23/2016 06:33 PM, Patrick Shanahan wrote:
zypper -v in --force digikam-libs
Command zypper -v in --force digikam-libs yielded Package
'digikam-libs' not found.

I will try more tomorrow.
Thanks for your help:-)
Don

If one downloads the digikam src RPM there many dependencies called for.
ImageMagick-devel is needed by digikam-4.3.0-2.2.x86_64
bison is needed by digikam-4.3.0-2.2.x86_64
boost-devel is needed by digikam-4.3.0-2.2.x86_64
doxygen is needed by digikam-4.3.0-2.2.x86_64
flex is needed by digikam-4.3.0-2.2.x86_64
libxml2-devel is needed by digikam-4.3.0-2.2.x86_64
libxslt-devel is needed by digikam-4.3.0-2.2.x86_64
baloo-devel is needed by digikam-4.3.0-2.2.x86_64
gstreamer-plugins-qt-devel is needed by digikam-4.3.0-2.2.x86_64
lensfun-devel is needed by digikam-4.3.0-2.2.x86_64
libeigen3-devel is needed by digikam-4.3.0-2.2.x86_64
libgpod-devel is needed by digikam-4.3.0-2.2.x86_64
libjasper-devel is needed by digikam-4.3.0-2.2.x86_64
libkdcraw-devel is needed by digikam-4.3.0-2.2.x86_64
libkde4-devel is needed by digikam-4.3.0-2.2.x86_64
libkdepimlibs4-devel is needed by digikam-4.3.0-2.2.x86_64
libkexiv2-devel is needed by digikam-4.3.0-2.2.x86_64
pkgconfig(libkipi) >= 2.0.0 is needed by digikam-4.3.0-2.2.x86_64
libkqoauth-devel is needed by digikam-4.3.0-2.2.x86_64
libMagick++-devel is needed by digikam-4.3.0-2.2.x86_64
libksane-devel is needed by digikam-4.3.0-2.2.x86_64
libkvkontakte-devel is needed by digikam-4.3.0-2.2.x86_64
liblcms2-devel is needed by digikam-4.3.0-2.2.x86_64
liblqr-devel is needed by digikam-4.3.0-2.2.x86_64
libpgf-devel is needed by digikam-4.3.0-2.2.x86_64
libqca2-devel is needed by digikam-4.3.0-2.2.x86_64
libqjson-devel is needed by digikam-4.3.0-2.2.x86_64
libusb-compat-devel is needed by digikam-4.3.0-2.2.x86_64
marble-devel is needed by digikam-4.3.0-2.2.x86_64
opencv-devel >= 2.4.5 is needed by digikam-4.3.0-2.2.x86_64
pkgconfig(glu) is needed by digikam-4.3.0-2.2.x86_64

Previously I have not tried to recompile an opensuse source RPM. Do I just
make a script and ask
zypper to install all if these packages. Or is there some automated way to do
it? Then I guess I
have to turn around and remove all of them? If I wish to build some of them
to support gdb, is there
a way to do all of this in some local directory?

In my past life I was able to keep all of my experimental builds separate
from the running system.

Don

Why not just use Yast?

Select the item you want, (digikam src RPM) from the source repository, and let
it worry about
the dependencies. These are all Developmental libraries, usually quite small.

But still you don't want to be micromanaging the install of individual RPMs.
There is probably an equivalent zypper to fetch all the dependencies, when you
install digikam src
RPM but writing a script is the exactly wrong thing to do.

We've spent 10 years trying to get away from RPM-Hell, and jumping back into it
is crazy.






--
After all is said and done, more is said than done.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups