Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] Failed login prompts on VTs
24.01.2016 14:59, Anton Aylward пишет:
On 01/23/2016 08:57 AM, Carlos E. R. wrote:
On 2016-01-23 13:22, Anton Aylward wrote:

I realise that "vga=" has been depreciated, but at the time it was the
only way I could get grub and the inital boot to use the full screen.

I still use vga=791 in one machine, it was the only incantation that
worked properly.


Indeed.
Back when I was in 11.x that's what it took to get the grub2 and the
initial book to recognise the newly arrived 1280x1024 LG Flatron.
Than and an extra
set gfxmode=1280x1024
in grub.cfg
As you say, it was the only incantation that worked properly.
Well, not 'only' But that family and varying the colour depth ...

So I've been playing around this weekend with the "command line" and now
without any "vga=" at all it seems to .... if not "work properly" than I
have a font I can live with and LINES=48

I emphasise that the "vga=" worked fine until kernel 4.3 or 4.4


This is interpreted by vesafb. So it really sounds like different driver
is used now. Can you upload dmesg output immediately after boot with
"good" and "bad" kernels?

I've tried looking through change logs but my google-savvy in this area
is deficient. So far I've found nothing that shines light on all this.
If anyone more familiar with the kernel change process can help, I'd be
interested in hearing.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >