Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
[opensuse] x11vnc is not working with TigerVNC viewer on Leap42.1
Hi - For years now, I have run the x11vnc server as an xinetd daemon using the following configuration for the service -

service x11vncservice
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/bin/x11vnc
server_args = -inetd -rfbauth /etc/vncpasswd -oa /var/log/x11vnc.log -env FD_XDM=1 -find -rfbport 5900
port = 5900
type = UNLISTED
}

and up until when I upgraded to Leap42.1, from openSuSE12.3 ;-) (yeah I don't change very often) this has worked fine. But now I cannot get a vncviewer on an openSuSE13.2 or 13.1 to connect to this system running 42.1 The things I have noted that are of interest, was that openSuSE switched to using VNC software from TigerVNC and the problem appears to be either with the server trying to define the display to connect to or in gaining authorization to connect to the display. The x11vnc.log shows the following ominous messages -

23/01/2016 17:40:33 x11vnc version: 0.9.13 lastmod: 2011-08-10 pid: 11698
23/01/2016 17:40:33
23/01/2016 17:40:33 wait_for_client: WAIT:cmd=FINDDISPLAY
23/01/2016 17:40:33
23/01/2016 17:40:33 initialize_screen: fb_depth/fb_bpp/fb_Bpl 24/32/2560
23/01/2016 17:40:33
23/01/2016 17:40:33 initialize_screen: -inetd mode: F_GETFL(stdin): 0x2
23/01/2016 17:40:33 initialize_screen: -inetd mode: F_GETFL(stdout): 0x2
23/01/2016 17:40:33 initialize_screen: -inetd mode and stdio is O_RDWR
23/01/2016 17:40:33 other clients:
23/01/2016 17:40:33 incr accepted_client=1 for 192.168.10.10:60784 sock=3
23/01/2016 17:40:33 Client Protocol Version 3.8
23/01/2016 17:40:33 Protocol version sent 3.8, using 3.8
23/01/2016 17:40:33 wait_for_client: got client
23/01/20ddd16 17:40:33 client progressed=1 in 0/0 0.000001 s
23/01/2016 17:40:33 client useCopyRect: 192.168.10.10 0
23/01/2016 17:40:33 client_set_net: 192.168.10.10 0.0002
23/01/2016 17:40:33 wait_for_client: running: env X11VNC_SKIP_DISPLAY='' /bin/sh /tmp/x11vnc-find_display.A0fqoe
23/01/2016 17:40:34 wait_for_client: find display cmd failed.
23/01/2016 17:40:34 wait_for_client: bad reply '


A quick glance at the x11vnc code seems to indicate that the server was looking for a response starting with DISPLAY and failing to find it, it gives up and throws out the "find display cmd failed" message. Caveat, I only took a quick glance at the code which I found a copy of on the internet, so have not grokked it fully.

Other observations, I did try manually starting the x11vnc server, without any extra parameters,

x11vnc -display :0

and with these parameters -

x11vnc -rfbauth /etc/vncpasswd -oa /var/log/x11vnc.log -find -rfbport 5900

then connected to it from a client using the TigerVNC viewer, which works fine i.e.

vncviewer far-host:0

and this confirmed that at least the vncpasswd file was set up correctly and accepting my password.

But I really want to run it as a daemon process so that it will always be available to people (on an internal network) who do not know how to use SSH connections.
For grins, I tried setting the xinetd servers args for x11vnc to the following, also with no joy.

server_args = -inetd -rfbauth /etc/vncpasswd -oa /var/log/x11vnc.log -auth guess -find -rfbport 5900

I was suspicious about setting the env parameter "-env FD_XDM=1" but removing it and substituting the "-auth guess" did not succeed either.
Anyone else seeing problems with x11vnc or my method of running it as a server? Thanks in advance for any and all offers of help...

Marc...


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages