Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] digikam crashes
* don fisher <hdf3@xxxxxxxxxxx> [01-23-16 18:41]:
On 01/23/2016 04:08 PM, John Andersen wrote:
On 1/23/2016 12:57 PM, don fisher wrote:
On 01/23/2016 12:59 PM, John Andersen wrote:
On 01/23/2016 11:48 AM, don fisher wrote:
On 01/23/2016 08:26 AM, Carlos E. R. wrote:
On 2016-01-22 22:21, don fisher wrote:

I did a search for libthread under Yast2, with the contains switch, and
is says there are no results. But the same Yast2 code lists libthread_db
as a dependency.

cer@Telcontar:~> l /lib/
-rwxr-xr-x 1 root root 34555 Aug 5 12:01 /lib/*
cer@Telcontar:~> rpm -qf /lib/
cer@Telcontar:~> rpm -qf /lib64/

It comes in a different library.

Thanks. Do you know how I determine what library it is part of? I did a
YaST2 search, with the
switch contains, and received no results. I though the contains switch
was supposed to inform a user
of what package some component is contained in.


He showed you a command line example of how to do that. (two of them).

In Yast, Contains means you are giving a partial name.

You want to check the RPM provides box, as well as setting search mode to
"contains" or "begins with".

sorry to be so dumb about this. I turned on the provides, as well as
contains, and get nothing unless I reduce the search string to
"libthread_db". I received glibc-2.19-16.18.1, and under installed version
it listed 2.19-16.18.1, which matches. Below, where I thought is
was saying provides, there are numerous entries for

So my question is, how does one install the glibc-2.18-4.38.1.x86_64
package referenced above, and what impact will installing an older
revision have on my system.

Can both exist at once?

This is where Yast really shines.
Go into yast, select just the glibc-2.18-4.38.1.x86_64 and select install
option. If there is a conflict it will tell you
and you can bail out. If it says its going to load in a boat load of
additional packages, you might also choose to bail out
at that time.

But its FAR BETTER to let yast handle the whole thing than to end-run it and
start installing packages.

If Yast says the dependencies for Digicam can't be met, then you might need
to add another of the suse repositories
or you might need to wait a week for the repositories to catch up. Or file
a bug report.

Shouldn't digikam be rewritten/compiled consistent with the current

Yes it should be, and it probably will be. If you put this issue aside for a
week or
two it probably will solve itself.

And by Yast I mean Yast2

I do no know how to get Yast2 to show glibc-2.18-4.38.1. The only glibc
shown is 2.19-16.18.1, the currently installed version. As an alternative I
looked at rebuilding digikam from the src RPM, but 31 additional packages
are required. So while it may be a great exercise, I do not dare attempt it
at this point. How can I find out if anybody is doing a rebuild? Along the
same lines, how does one find the status of bug reports? I filed one, and
there is nothing under my bugzilla account. Is there an index somewhere?

zypper -vv in --force digikam

will reinstall digikam and display discrepancies
and probably will correct errors on your system by offering to install
the correct libs. I *is* supposed to.

zypper ve will verify that correct file dependencies are installed on your
system, and note problems.

use the force, luke
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri openSUSE Community Member facebook/ptilopteri Photo Album:
Registered Linux User #207535 @
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups