Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] darktable update
On Wed, Jan 20, 2016 at 6:00 PM, buhorojo <buhorojo.lcb@xxxxxxxxx> wrote:
On 20/01/16 22:36, Greg Freemyer wrote:

On Wed, Jan 20, 2016 at 3:46 PM, buhorojo <buhorojo.lcb@xxxxxxxxx> wrote:


I just initiated a test build of darktable factory rev 52 on a Leap
42.1 install. It took 20 or so minutes to run and I now have RPMs for
darktable 1.6 built against factory.

Feel free to try the above and ask questions about any roadblocks you hit.


Phew! Thanks. OK.

Whilst we're here, what do you reckon to that method vs the code from here:
https://github.com/darktable-org/darktable/releases/tag/release-1.6.9

How do you rate our chances of getting it built?

You can go either way, but once you know "osc" it is often much easier
to let it do 90% of the work. I routinely compile programs via "osc
build", but I bet is has been a year since I manually typed "make" at
a command line. I prefer to have osc do it for me.

I would at a minimum look at the specfile for the package before
deciding. It shows you exactly what the build commands are that
openSUSE uses. It also shows you any patches, etc. that are applied.

If the specfile is simple, then it might well be easier to do a manual
build. If is complex, I would stick to using "osc". For darktable
the only slightly intimidating part is all the buildrequires
statements.

https://build.opensuse.org/package/view_file/openSUSE:Factory/darktable/darktable.spec?expand=1&rev=6176ee32a7c958e86f296a550acfd026

If you try a manual build first note all the BuildRequires in the
specfile: You will need to ensure the packages for these are
installed before you start. If it says pkgconfig() then you need to
install the devel package for that package.

==
BuildRequires: cmake
BuildRequires: dbus-1-glib-devel
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: intltool
BuildRequires: lensfun-devel
BuildRequires: libcolord-devel
BuildRequires: libjpeg-devel
BuildRequires: libtiff-devel
BuildRequires: libxslt
BuildRequires: pkg-config
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(GraphicsMagick)
BuildRequires: pkgconfig(OpenEXR)
BuildRequires: pkgconfig(dri)
BuildRequires: pkgconfig(exiv2)
BuildRequires: pkgconfig(flickcurl)
BuildRequires: pkgconfig(gnome-keyring-1)
BuildRequires: pkgconfig(gtk+-2.0)
BuildRequires: pkgconfig(json-glib-1.0)
BuildRequires: pkgconfig(lcms2)
BuildRequires: pkgconfig(libcurl)
BuildRequires: pkgconfig(libglade-2.0)
BuildRequires: pkgconfig(libgphoto2)
BuildRequires: pkgconfig(libopenjpeg)
BuildRequires: pkgconfig(librsvg-2.0)
BuildRequires: pkgconfig(libsoup-2.4)
BuildRequires: pkgconfig(sdl)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(xrandr)
BuildRequires: pkgconfig(libsecret-1)
BuildRequires: pkgconfig(libwebp)

%if 0%{?suse_version} < 1315 # (1315 is leap and 1320 is
openSUSE 13.2)
BuildRequires: libGraphicsMagick3
%endif

%if 0%{?suse_version} && (0%{?suse_version} > 1210 && 0%{?suse_version} < 1321)
BuildRequires: lua-devel
%else
BuildRequires: lua52-devel
%endif

BuildRequires: pkgconfig(libopenjpeg)
BuildRequires: xz
==

Greg
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >