Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] gnuplot -p plotfile.plt (no zoom, scale, etc.) no communication with persistent window??


On Tue, 19 Jan 2016, David C. Rankin wrote:

On 01/19/2016 04:19 PM, Serafino Conflitti wrote:
I have the same version running on os 13.1.

When you say "like all communication", do you mean from the
mouse to gnuplot or gnuplot keyboard to the window or both?

Serafino

I mean partially from both. When I run with 'gnuplot -p plotfile.plt', pressing rt-button (drag) rt-button (click) does not 'zoom'. pressing 'h' does not output help to the terminal, clicking on any of the toolbar tools does nothing e.g. ['Replot', 'Show Grid', 'Previous zoom', 'Next zoom', 'Autoscale']

It is like it has lost its terminal context. (which makes some sense, but it has always worked before) But running from the gnuplot> prompt -- everything works.

Try it on the two attached files.

Test (1)

$ gnuplot -p vmag.plt

(try and turn grid on/off, zoom, etc. -- doesn't work)

Test (2)

$ gnuplot
gnuplot> plot "vmag.txt" using 1:3 title 'velocity y', "vmag.txt" using 1:5 title 'velocity'

(try the same -- it works)

I recall it working regardless of how the plot was created, but I can't think of what change would have caused any difference in behavior now.

attached:

vmag.plt - plot file
vmag.txt - data file

--

Thanks for the files. I tried them and seem to get the same results as you.

In my plot files I usually put a pause command right after the plot
command. I inserted it into your plot file and it seems to work
with and without the -p.

<code>

plot \
".vmag.txt" using 1:3 title 'velocity y', \
".vmag.txt" using 1:5 title 'velocity'
pause -1 "Press enter to continue or quit"

</code>

This is the first time I've seen gnuplot using the qt window.
It looks nicer than the X11 window.
Thanks.

Serafino

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >