Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] dracut emergency shell - where to mount root?
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Mon, 18 Jan 2016 18:41:46 +0100
  • Message-id: <n7j84q$6c1$2@saturn.local.net>
Andrei Borzenkov wrote:

18.01.2016 14:38, Per Jessen пишет:
In earlier openSUSE releases, I'm sure I used to mount on /dev/root
and then leave the emergency shell with exit or Ctrl-D ?

With dracut emergency shell, I have tried /dev/root and /sysroot,
both found on the 'net - neither seems to work. I've tried openSUSE
13.2 and Leap both.

Background - afaict, dracut or yast does not correctly create an
initrd when root is on nfs. For the first boot, I would therefore
manually mount root and continue, then correct the initrd.


dracut is based on systemd today; which means when it enters emergency
mode because some unit fails, when you exit it with ^D it still tries
to start the exactly same unit and it will likely to fail at exactly
the same place. In particular, if at startup systemd generated "bad"
unit, this unit remains - you need to either directly fix generated
unit and run "systemctl daemon-reload" or fix the source of generated
unit and run "systemctl daemon-reexec" to make it run generators
again.

What exactly failed? Can you display failed units?

This is related to the other issue with ip=enp65s1:static etc.
Basically the network setup fails, which means the root filesystem
can't be mounted. To work around a poorly created initrd, I have
usually been able to manually mount root and then continue. In this
case I just manually configured the interface, mounted the nfs root,
and wanted to continue ...


--
Per Jessen, Zürich (-7.1°C)
http://www.dns24.ch/ - free dynamic DNS, made in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >