Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] Question Leap: fonts and colours
On 15/01/16 00:25, Anton Aylward wrote:
On 01/14/2016 02:29 AM, Basil Chupin wrote:
Why am I getting a different result when using Leap to what I get in
13.2? Anyone have a suggestion, or two, please?
I have a recollection of this or something similar when upgrading to
13.1 and possibly 12.<something>. I can't find explicit mention in my
notes, but that was also accompanied by a new drive and restoration of
$HOME from backup and then a new machine. It the sort of thing that got
lost in the details of configuring new hardware.

One of my perennial gripes is that too much of the software I consider
essential is geared for Gnome and I'm a KDE users.

YES IT IS A RELIGIOUS ISSUE, THANK YOU!

I understand, my son. Flaggelate yourself for 1/2 hour for the next week
and seek forgiveness from the Gnome god.


My vague recollections include having to modify things in Gnome terms
for colour and font. I have an explicit note on that for the background
colour, font for Darktable, another of my 'software crutches' that uses
GTK rather than QT.

Thunderbird requires libfontconfig.o (among others) and an investigation
of that gives some clues as to caching and where the installed fonts
live, notable /usr/share/fonts. I can image that a customized set of
fonts in the library might be reset, somehow, with a new installation.
Perhaps you need to do a dirdiff between that library, as well as the
cache, between the two installations, somehow.

I also note that there are many settings such as

FONTCONFIG_USE_MMAP
XDG_CACHE_HOME
XDG_CONFIG_HOME
XDG_DATA_HOME
FONTCONFIG_FILE
FONTCONFIG_PATH
FC_DEBUG

that you can play with.

I have no intentions of playing with this or anything :-) .

If it don't woik then phuk it, I say! :-) .


If I had the time and patience I'd pour over the source code to see
what's going on. I don't. YMMV.

That being said, there seems to be many possible error messages in
libfontconfig. I wonder what the logs show?

I am also wondering same .....


BC

--
Using openSUSE 13.2, KDE 4.14.9 & kernel 4.4.0-2 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX660 GPU


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >