Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] Network set up after crash
On 01/15/2016 10:55 AM, Per Jessen wrote:
don fisher wrote:

On 01/15/2016 12:17 AM, Per Jessen wrote:
don fisher wrote:

On 01/14/2016 03:31 PM, don fisher wrote:
On 01/14/2016 03:04 PM, Anton Aylward wrote:
ifconfig -a
I did the ifconfig as you suggested and it just listed the three
devices as expected. I think something is broken in my routing
maybe? When I click on an old link in thunderbird it claims it
cannot reach But if I enter just into
Google it opens, so the rest of the link cannot be resolved. I will
not open my online banking window or other links I used to open all
of the time. When I try to connect to the name server listed in my
resolve.conf I receive a "Network is unreachable" message. But
again, Google finds it.


I tried the ifroute man page, and none of the files suggested


exist on my system.

They only exist if they are configured - i"froute-interfavce" only if
you have interface specific static routes, and "routes" if you have
static routes. On a single user machine most probably using DHCP, you
don't need any of those.

Don, we don't really know your level of expertise here, but YaST will
sort all of this out for you. YaST->Network Settings->select network
card->set for dhcp->done.

Thanks for the suggestion:-) DHCP works. I was using statically
assigned IP addresses to make my inter machine communication easier. I
guess now all I have to do is determine what I am missing in setting
up static IPs. Static IPs worked previously.

You can also assign those with YaST.

As an experiment I tried going back from DHCP to my static address and
things were broken again. Any ideas on what is required under Yast (or
elsewhere) to allow the static address to find routes to the net, if
that is what is broken.

If you assign an address of e.g., a /24 route will be
automagically created. Anything else you will have to do yourself -
YaST will help you setup the default route and any other static routes
you want. Do you actually have multiple separate networks?

I do not have multiple separate networks. But I have never been able to get the dynamically assigned IP address associated with host name. I did what you suggested, but I put the /24 in the subnet mask entry. Can you suggest how Yast helps set up the default route? Again, I do not recall having to do anything special in the past. I did add my gateway address and select a device, and now the static address appear to work:-))

Thanks very much!

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >