Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
[opensuse] 13.2, 42.1, TW "installed" printer cannot print on any installation except one 42.1
[No replies from factory list since sent Friday AM, so reposted here.]

Patrick Shanahan composed on 2016-01-07 16:56 (UTC-0500):

Felix Miata composed:

Patrick Shanahan composed on 2016-01-07 16:16 (UTC-0500):

did you try:
systemsettings5 -> printers

As far back as I can remember I always got YaST2 to do it, so didn't even
think to look there.

re: Configure Desktop -> printers

I switched to a different machine to try, and TW instead of 42.1,
plasma5-workspace-5.5.2-1.1.x86_64. System Settings menu has no printer
selection to try. It has in hardware:
input devices
display and monitor
multimedia
power management
device actions
removable devices

So I tried localhost:631. It claimed to have created my printer, but print
test page fails with simply: "Print Test Page <name> Error. Unable to print
test page: No such file or directory"

Appears you put your end-of-msg and sig a little early....
(or maybe that is an attachment that didin't *attach* correctly in your
client).

My copy's attachment looks exactly right.
http://lists.opensuse.org/opensuse-factory/2016-01/msg00106.html does too.

these lines may give you some guidance:

D [07/Jan/2016:16:23:43 -0500] [Job 3] Unable to auto-configure PostScript
Printer - no bidirectional I/O available!
D [07/Jan/2016:16:23:43 -0500] [Job 3] PID 17905
(/usr/lib/cups/filter/commandtops) stopped with status 1.
D [07/Jan/2016:16:23:43 -0500] [Job 3] Hint: Try setting the LogLevel to
"debug" to find out more.
D [07/Jan/2016:16:23:43 -0500] [Job 3] PID 17906 (/usr/lib/cups/backend/lpd)
exited with no errors.

No luck finding me anything helpful.

do you have the correct ppd file?

There is only one, in /opt/brother/Printers, with symlinks in
/usr/share/cups/model/ and /usr/shre/ppd/brother/.

To somewhat reiterate the problem, then describe events of the day:

1-I installed 42.1 two weeks ago on this machine, including Brother's
cupswrapper and lpr driver rpms for my printer, successfully and without
incident (instructions on
http://support.brother.com/g/s/id/linux/en/before.html?c=us_ot and
http://support.brother.com/g/s/id/linux/en/instruction_prn1a.html?c=us_ot and
http://support.brother.com/g/s/id/linux/en/instruction_prn3.html?c=us_ot via
http://support.brother.com/g/s/id/linux/en/index.html?c=us_ot ) then set it
up successfully via YaST2 printer module, printing the YaST2 test page and
multiple pages from various apps.

2-Tuesday I encountered trouble printing one particular web page with 6
different Gecko browsers, but not with Firefox 10 or Konq3. This turned out
to be an apparent problem with (my bank's bill pay) report page intended for
printing, which I reported by email and phone to my bank's web support
department.

3-Earlier today when my bank responded with instructions via email, I
followed those I hadn't already done.

4-I then attempted to verify the problem isn't limited to this PC by trying
to print the same page on another PC, host hpg33. My first try was to have
been on one running 42.1, but the YaST2 printer driver installation process
wasn't resulting in ability to print a test page. I confirmed printer
functionality by printing from this 42.1 host, msi85.

5-Next I tried on a third PC, host gx745, this time with Tumbleweed/Plasma
and 13.2/KDE4. The YaST2 test page failures repeated, so I deleted those,
then created one via localhost;631. It claimed to succeed, but test page
print again failed. I deleted that one too, then tried installing via
Brother's installation shell script. It too failed at the test page step. At
various times I confirmed printer still works by printing from this 42.1 PC.
http://fm.no-ip.com/Tmp/Linux/Print/BR5470/vtcap.txt is a screen dump from
running the script.

6-Pain in my back like never before experienced began, interfering with
thought processes and thus inhibiting progress finding the problem.

7-I tried on a fourth PC, host gx62b, again TW and K5. Nothing different.
Test page failed. Again I reconfirmed ability to print on this 42.1 PC.

8-I returned to 42.1/K5 host hpg33, tried a couple of times again to create
via YaST2 printer, without improvement, so I exited Plasma, and used zypper
to remove *cups* packages, which also uninstalled ghost*, 5470 printer rpms,
and most of K5.

9-I restored OEM versions of zypp.conf and and zypper.conf, then zypper
installed every *cups* and ghost* rpm that I found installed on this PC. That
installed packages that hadn't previously been installed.

10-Before reinstalling K5 with zypper, I restored my edited zypp.conf and
zypper.conf (disabling recommends/suggests). I followed up installing K5 by
again installing the 5470 rpms.
http://fm.no-ip.com/Tmp/Linux/Print/BR5470/cupspkgs-hpg33-os421d.txt lists
the currently installed print (AFAIK) related packages.

11-After perusing https://wiki.archlinux.org/index.php/CUPS/Troubleshooting I
set debug in /etc/cups/cupsd.conf, then rebooted 42.1.

12-Configuring printer via YaST2 again wouldn't print a test page, so deleted
that one and tried one with localhost:631. On completion, CUPS reports state
stopped "filter failed", even though I didn't find any button to push to ask
for a test page. Reprint button doesn't cause printer activity.
http://fm.no-ip.com/Tmp/Linux/Print/BR5470/cups-accesslog-hpg33-os421f.txt

Scattered among the above steps were excursions to Google looking for what to
do about various error messages, starting with those quoted by Patrick.
Another was 'Bad driver information file "/usr/share/cups/drv/..', so I
compared those two files between this machine and hpg33, and found identical
timestamps and file sizes. Nevertheless, I stopped cups, then copied those
two files from this machine to hpg33, then rebooted,, reloaded localhost:631,
asked for a test page, and again got nothing from the printer, with latest
job showing as having been completed.
http://fm.no-ip.com/Tmp/Linux/Print/BR5470/cups-errorlogdebug-hpg33-os421g.txt
indicates
no "E" errors occurred.

During the setups, the IP connection test always succeeds. Host hpg33 can
ping the printer successfully too.

http://fm.no-ip.com/Tmp/Linux/Print/BR5470/ has many logs accumulated, mostly
from host hpg33, split into mutiple files corresponding roughly to different
boots. noteworthy is its cups page_log dates back to installation of the
first cups packages, and remains 0 bytes. NAICT, the access_logs all indicate
nothing but apparent successes.

If it wasn't for this machine able to print, I would have to think there's a
bug here somewhere causing a failure to print without any log indicating that
printing did not occur. But I suspect if there is a bug, it's a missing
package that should be a dependency but isn't.

My head's swimming in confusion, frustration, and back pain, after around 15
hours buried in this.

Can anyone see in any of those logs what I need to do to get any 13.2, 42.1
or TW installation besides this one to print anything?
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups