Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] Strange update problem - Leap 42.1
On 01/08/2016 04:22 PM, Darryl Gregorash wrote:
On 08/01/16 08:00 AM, Gustav Degreef wrote:
On 01/07/2016 10:42 PM, Darryl Gregorash wrote:

snip
Then, fire up Yast/Software Management and
search for everything that depends on libzypp. Everything that is
installed (here there are 8 packages, default installation) likely needs
to be /forcibly/ refreshed.
Snip

I think I understood most of your suggestion. However, the above is not
clear to me.
I found these 7 packages that depend on libzypp. Do I forcibly remove
all and re-install all of them?
No, you don't need to remove them. On the yast menu bar, click
Packages/All in this list/Update unconditionally.

That will re-install any packages already installed, but will not add
any new ones.

PS, since this might be just a libzypp problem, you can probably update
just that one package. Hopefully that would be enough.
The result was very strange! I reinstalled libzypp as indicated - as
the first step. Then I was able to refresh all the repositories (which
had been failing). After that I did "zypper patch" and it completed
successfully without errors. So far so good.

I then tried "zypper up" and but got the same failures to connect to the
packman repo as before! I then tried to reinstall the remaining 7
packages (dependencies of libzypp) via yast. But that failed with the
error that the system could not connect to any of the repoertories. The
following is a sample error message (from zypper - at that same time point):

linux-tz21:/home/rada # zypper ref
Download (curl) error for
'http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content':
Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80:
Network is unreachable

Abort, retry, ignore? [a/r/i/? shows all options] (a):

There is no particular repo failing, all of them fail. Packman seems to
fail most often, but when trying to update the libzypp dependencies all
of the repos are unreachable.

I've never had anything like this happen in all the years of using
suse! Thanks for the help, Gustav.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >