Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] Strange update problem - Leap 42.1
On 01/07/2016 01:23 PM, Harrie Baken wrote:
Hallo Gustav Degreef, op 07-01-16 om 12:00 schreef je:
Hello,

I have been unable to update (via zypper, YOU or apper) since some
time. It behaved normally after the initial install for some weeks.
I can ping "google.com", Skype is working fine and I can access web
pages with FF. But Apper says that the "network is offline". YOU
fails to access multiple respositories. Also when I try to add a
repository, I reach the page where I can select the community
repositories but then I click next it gives the error that it failed
to find any list of repositories.

I have 13.2 on separate partitions and it behaves perfectly fine.

On leap, Zypper gives the following:


linux:/home/user # zypper patch Download (curl) error for
'http://download.opensuse.org/update/leap/42.1/non-oss/repodata/repomd.xml':



Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80:
Network is unreachable

[etc.]

Your connection must have failed. Nothing wrong with the repos:

har@harbeidbak:~> curl -I
http://download.opensuse.org/update/leap/42.1/non-oss/repodata/repomd.xml
HTTP/1.1 200 OK
Date: Thu, 07 Jan 2016 12:17:10 GMT
Server: Apache/2.2.12 (Linux/SUSE)
Last-Modified: Wed, 28 Oct 2015 20:01:27 GMT
ETag: "7ee-5232fa8dc53c0"
Accept-Ranges: bytes
Content-Length: 2030
Cache-Control: must-revalidate
Expires: Thu, 07 Jan 2016 12:17:10 GMT
Content-Type: text/xml

har@harbeidbak:~> curl -I
http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content
HTTP/1.1 200 OK
Date: Thu, 07 Jan 2016 12:18:02 GMT
Server: Apache/2.2.12 (Linux/SUSE)
Last-Modified: Wed, 28 Oct 2015 21:18:05 GMT
ETag: "b4d-52330baec3d40"
Accept-Ranges: bytes
Content-Length: 2893
Content-Type: text/plain

Harrie

Thanks for the reply. But Skype, FF and ping "google.com" works fine.
The problem only seems to be with accessing the repos. As you point out
the repos are fine, so the problem is elsewhere. What can explain that
all three - Yast online update, zypper and Apper all are failing, but my
network seems ok? Gustav

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >