Mailinglist Archive: opensuse (1047 mails)

< Previous Next >
Re: [opensuse] slow desktop action and hangs after upgrade to 42.1
It is pretty standard procedure.

The .kde4 directory shouldn't get in the way of .kde5 (if that is what Leap uses) but it would have on any Ubuntu system, (or Kubuntu) where kde4 was installed in .kde, as well as kde5 for later versions (was also installed there).

Typically there is no way to know unless you know everything about everything about everything impossible to know,

whether or not there is going to be some conflict particularly in the .config directory, but .local could also have an impact.

Ideally this should not happen: a new version of KDE should work in a different directory (.kde5) and it should not interfere with .kde4.

So what this means is, apparently something was using .local, but .cache could also be a culprit.

So the answer to your question is: yes, you need to at least delete .cache, and possibly .local and .config.

It's unfortunate that it works this way because it also means keeping two versions of e.g. KDE together on the same home volume is difficult.

Then, having a shared home between many (or more) (or multiple) installations of Linux is very difficult.

This would require one of the following:

- use only a shared folder for non-dot files
- hand pick the hidden files you want to share (such as .thunderbird) and put them on an overlay filesystem that is overlayed on top of the "real" "current" home directory.

I was experimenting with this on Kubuntu but then I ran into trouble with OpenSUSE because the "aufs" filesystem I used on *Ubuntu is not available on OpenSUSE.

My idea was:

- put the non dot files on a volume shared between distributions
- create on each distribution an overlay between that shared volume, and the root volume for that distribution, where the shared volume would take precedence, but all dot files created during installation (on the root fs) would be maintained on the root fs.

In this way each distribution could create its own .config .local etc. hierarchies during installation, but they would get masked by the /SHARED/ versions of those files (and directories) if and only if the shared volume did have a version of it.

You could then simply turn any .file into a shared file simply by copying it to the shared folder. The shared volume.*

But that aside.


Aufs was not available on OpenSUSE and it increases the maintenance cost of a non-standard system, so I haven't used it anymore.


Regards.




George Olson (SUSE list) schreef op 02-01-2016 1:02:
Hi everyone,

I just finished the installation of 42.1 in my laptop (#2 below). I am
now tweaking it to make it work. My installation was a clean install
of 42.1 into a separate root partition from my root partition of 13.2.
I installed by means of the install dvd which I downloaded.

My home partition I am using is the same as the home partition I used for 13.2.

First problem - the graphics driver - fixed (I think). It is an intel
i915 card with a discrete nVidia GM107M graphics card. I installed
bumblebee with the proprietary nvidia driver according to this:
https://en.opensuse.org/SDB:NVIDIA_Bumblebee

After that my system was able to boot into opensuse and kde. The
hwinfo --gfxcard indicates that both the i915 driver and the nvidia
driver are the ones installed.

Second problem - KDE had a significant delay whenever I tried to do
anything. When I clicked on any icon, I had to wait between 10 and 30
seconds for the application to give any indication that it is opening
up. It didn't matter if it was kwrite, konsole, the kicker button,
yast, or firefox or chrome. Also if I hit alt-tab to switch between
applications, sometimes I would have to wait for that to switch also,
and watch the desktop hang.

I tried disabling desktop effects and switching the display backend
driver to openGL something, and that seemed to help for about 1
minute, but then the delays and hangs would come back at random.

I finally resorted to the following, and this is where my question is.
Since I was using the same home partition as I was using for 13.2, I
thought maybe there was some conflict between old KDE 4 files and
whatever KDE 5 wanted to do. So I went into the /home/george directory
and deleted all the hidden directories (that have a . in front). This
included the .kde4 directory, .config, and .local. (I kept the ones I
needed for applications like thunderbird).

After I did that, I logged back into KDE, knowing it would re-create
from scratch what it needed to run KDE 5, and voila, now the system
works quite speedily, no more hangs. Pretty nice so far. Haven't
really tested it extensively, but it seems much better.

I am wondering if this is sort of standard practice when going to a
new version of KDE? It seems that this should be written down
somewhere. I saw several posts in the forums where others were
struggling with similar problems of their system hanging, and there
were suggestions of turning off desktop effects and disabling device
acceleration, and other ideas.

Thoughts? Would there have been a better way to make things work?

--
George
Box #1: 13.2 | KDE 4.14 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
Laptop #1: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB
Laptop #2: 42.1 | KDE Plasma 5 | Core i7-4710HQ | 64 | 16GB
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >