Mailinglist Archive: opensuse (911 mails)

< Previous Next >
Re: [opensuse] Leap on Lenovo 201 - failure to start any x session
28.12.2015 20:55, stakanov@xxxxxxxxxx пишет:
-----Ursprüngliche Nachricht----- Von: Andrei Borzenkov Gesendet:
Mo. 28.12.2015 07:59 An: stakanov@xxxxxxxxxx Kopie: SuSE Linux ,
Betreff: Re: [opensuse] Leap on Lenovo 201 - failure to start any x
session

On Sun, Dec 27, 2015 at 9:11 PM, wrote:
I tried to install Leap on a Lenovo X201, all updates during
install.

Results so far: if you password protect grub, it works but the
unlocking in order to access a "failsafe
setting" does not work.

I do not understand this. You have "failsafe setting" menu entry?
When you select this menu entry you need to authenticate? What
happens when you authenticate?


No, I did reinstall everything. I have now leap running but curiously
also no I do NOT have a "failsafe" entry in grub. I have advanced but
if I choose it i have the very same entry without possibility to
enter any parameter.

I'm still not sure if we speak about the same thing. Advanced is submenu
(and has always been) which lists menu entries. You can edit each menu
entry as was always possible. If you set password protection you need to
authenticate yourself before you can edit them (because it effectively
gives you access to full CLI at this point).

If I have it password protected I have to press
escape, then it asks me for the user (that I suppose is root?) and

Yes, YaST should provide better explanation about user name that it
uses. Yes, in grub2 there could be multiple users; YaST picks "root" but
you can also define others.

The problem with returning from submenu was mentioned upstream. We need
to revisit it probably. Could you open bug report for openSUSE?

for a password which is the one of grub). If I do so, it just brings
me....back to the grub without any possibility to set up boot
parameters.

E-h-h ... I presumed you knew that in grub2 you edit menu entry by
pressing 'e'. Default for upstream is to provide explanatory text when
menu is displayed; SUSE decided to remove it in their theme.

If you have any idea why
the fail-safe entry is not there...I will be grateful to try.


IIRC it was removed intentionally, but do not ask me why. I do not even
know which program does it (I do not see it either in grub2 RPM or in
yast-bootloader). You can re-enable it by commenting out
GRUB_DISABLE_RECOVERY=true in /etc/default/grub (and of course
re-creating grub.cfg).
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References