Mailinglist Archive: opensuse (911 mails)

< Previous Next >
Re: [opensuse] "no valid journal superlock found" on mkfs & mount ext4

Are you sure you don't have a fake usb stick? A common problem are usb
sticks that only have a fraction of the printed capacity.If you reach
the end of the storage device, you get redirected to the beginning.
badblks is happy with it, but filesystems are not.

On 12/11/2015 02:25 PM, Anton Aylward wrote:
More backup woes.

I let badblks run overnight to verify a newly acquired large (128G) USB
and am happy with the results.

Now I come to put a file system on it.

First, I try creating an ext4 file system. I'm going to play with
various "T" options, but lets start with the basics.

I do the mkfs.ext4 taking defaults, when its done I sync and try mounting.

I get this

[63849.264471] JBD2: no valid journal superblock found
[63849.264478] EXT4-fs (sdb1): error loading journal


So I try with an explicit journal creation - "-j" and yes that makes a
not about creating the journal appear on the CLI.

Again I try mounting. Same error.

I try combining with various "-T" options, various "-J".
Same result.

For completeness, even though I'm a CLI guy and, as you can see, I'm
minimalist, I try yast.
That seems to create a ext4FS that it mounts.
I look over the yast2 logs but they aren't easy to decipher. it seems
that with yast EVERY parameter is there! far from minimalist!


When I unmount and reinsert that USB I'm back to the old error message
about no valid journal superblock. It seems Yast isn't that great after

Next up, I try mkfs.reiserfs with default settings.
The resulting formatted USB mounts with no problem.

I'm hesitant to use that for backup despite the matter of inode
exhaustion since the threading of reiserfs on the USB along with the
reiserfs of /home can get knotted. Take that as it DOES, I just tried it.

Next up is XFS. Well XFS doesn't seem very USB-friendly.
It formats, but when i try mounting it hangs. and I can't ctrl-C to get
out of the mount loop.

So much for using a large USB stick for backups!

Any suggestions as to what might be the problem with ext4?
Or XFS for that matter?

I'd really like a well balanced FS, and one problem I keep running into
with many situations is inode exhaustion. Its why I've turned to
reiserfs and do actually use BtrFS.

< Previous Next >
Follow Ups