Mailinglist Archive: opensuse (729 mails)

< Previous Next >
Re: [opensuse] konsole dictating dimensions of gvim window
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

It is weird indeed. The windows is resized exatcly as it should for me here. By the way you say that your version of gvim/vim is 7.4.729, but in the official 13.1 reposotiry the latest version is 7.4.052. From where did you installed yours ? Directly from a source (it seems as the latest one according to https://code.google.com/p/vim/source/browse/)?

Regards,
I. Petrov

On Fri, 5 Jun 2015, toothpik wrote:

On Fri, Jun 05, 2015 at 11:29:09PM +0300, I. Petrov wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

On Fri, 5 Jun 2015, toothpik wrote:

On Thu, Jun 04, 2015 at 05:43:23PM -0400, Anton Aylward wrote:
On 06/03/2015 08:34 PM, toothpik wrote:
I am running openSUSE v 13.1, konsole v 2.11.3, gvim v 7.4.729

if I start a gvim session from the konsole command line it assumes the
same dimensions as konsole -- if I instead start gvim from the alt-F2
run starter it assumes whatever dimensions I have specified in my
startup script, or it defaults to a cute 25 line by 80 column display

can someone tell me how to end the tyranny of konsole sizing my gvim
windows?

I wonder if you have aliasing vis 'search' going on.

no aliases for vim, but I use the heck out of sym-links -- g for gvim
and v for vim -- much easier to type and totally irrelevant to the
resizing problem

if i use 'gvim' i get small windows, but different positions for each of
your two use cases.

but if in the xterm of the konsole window I run 'vim' or 'vi' it appears
as you describe, the complete window.

as it is designed

When I run 'alias' I don't see anything to do with vim or gvim or vi
Please don't get confused between bash's 'alias' and the email alias
mechanism.

yes I know what aliases are in bash -- I have dozens of them for
changing directory

There is also 'alternatives'. I don't have any set up for vim, gvim or vi

I know what vim I am executing, I compile it myself -- for me it resides
on /usr/local/bin, and this too is irrelevant to the resizing problem

I have a work-around, alt-F2, and hope we can end this thread -- clearly
no-one here knows how to end konsole's tyranny and poking around with
irrelevancies is helping no-one

Are you saying that delaying the execution of the .vim file by
adding a sleep command at the top of it, does not help ? Did you try
to increase the time e.g. to 500ms or 1s ?

it "helps," but it isn't a solution: with a second sleep the column
setting in the script is honored by the window manager, but the lines
setting, while honored by vim, is not honored by the window manager and
I wind up with a big swath of lines that aren't really there in the
bottom of the window -- there are 42 vim lines and 18 lines of
inaccessible nothing -- profoundly weird

it does the same with a two second sleep and a five second sleep

those inaccessible lines don't go away even after the session has
started and I issue a

:set lines=42

command -- something in kdm or kde is holding that window to 60 lines
and it won't let go unless and until I grab the bottom of the window
with the mouse and move it up

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Signed by Topal

iQIcBAEBAgAGBQJVciJAAAoJEH8sJoKRFRU5gnYP+wcqS5MrNKc5+e2PFdfd3wPO
B34tizQEwx19wKWtA93rFhAZhMLYwZ05Ww7tj7iuFHBcO8SZ7fmMaOi/joLMsClJ
jficxhYjmaSXw7km3ECNKpB3AAmh6ve1hthPqkBfMwI1i6WkLLj/FOVbv7lBJDFn
DpFLh/ELoQR/34h1yIUEa+aMg1hSGQRBzkv0GSF1s+h/B7M4TAv1ruAwVHHCrO6f
3vB4HxhBs0gVxsTq+8ik8H+gXKYvDHC2V2SbcqcPRv9ZXphA0qyviuAzLUJkPiQ3
9eQT8XGN3zeNpJQPEof3RRBXNeGQDnDuthIFrvTGsEPJjiLXAeH1DZC9uOIkCFdA
jVZZtAqaUS5yeBKmnYsbxDr6FLzBcJeAUbHYrQKgXoQAY5baSUK8fw1C6P5uOsK0
bqqX3tdVFKwdBYaL3AZ/Bc41Z7A7HusXMpTVg3Go8oFm0Iblx7SlEZWXdQ/U27Jp
Y3grCLJjt7o0mgMnf6/HibGNgUNncSYP1p2VrMPvc0WSvmNQBUh9dJDsDVIW5CuC
NXkVXebJpMIgDU0j1E9WQ8INJzgWkY3p3JEh8eWAfK8UDQq4FYJ3vwGDz0Fr1gba
VW6pYmDNBK8DSyskC3VMT2d0+Z6JLhYTXayeoWjNuCqnMDAGJY3IK2EDhNsXBgfW
kDOzebZE1nwaqPyl2qDS
=juQa
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups