Mailinglist Archive: opensuse (729 mails)

< Previous Next >
[SOLVED] Re: [opensuse] postfix - server rejecting e-mails from some of my kids devices, fine otherwise
On 06/04/2015 08:52 PM, David C. Rankin wrote:
On 06/04/2015 05:00 PM, I. Petrov wrote:
Hello,

The client is not authenticated therefore the mail is rejected. You should see
why the iPad does not make a login attempt. Alternatively you can modify the
smtpd_client_restrictions as follows:

smtpd_client_restrictions = permit_my_networks, permit_sasl_authenticated,
reject_unknown_client

and the same email should be accepeted whithout authentication.

Regards,
I. Petrov

Thanks,

I should have included that I had already tried that with a (postfix reload),
but I'll try it again with a restart and see if that changes anything.


Confirmed,

After changing the config:

smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unknown_client

The same error is received:

Jun 4 15:39:39 nirvana postfix/smtpd[18893]: connect from Sydneys-iPad.3111skyline.com[192.168.6.147]
Jun 4 15:39:39 nirvana postfix/smtpd[18893]: NOQUEUE: reject: RCPT from Sydneys-iPad.3111skyline.com[192.168.6.147]: 554 5.7.1 <Sydneys-iPad.3111skyline.com[192.168.6.147]>: Client host rejected: Access denied; from=<kids_email> to=<my_remote_email> proto=ESMTP helo=<[192.168.6.147]>
Jun 4 15:39:39 nirvana postfix/smtpd[18893]: disconnect from Sydneys-iPad.3111skyline.com[192.168.6.147]

But that got me thinking about the master.cf settings. Sure enough, I had:

submission inet n - n - - smtpd
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
-o milter_macro_daemon_name=ORIGINATING

Changing smtpd_client_restrictions there to:

smtpd_client_restrictions=permit_mynetworks,permit_sasl_authenticated,reject

solved the issue. Thanks for jump starting my memory :)

--
David C. Rankin, J.D.,P.E.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >