Mailinglist Archive: opensuse (1620 mails)

< Previous Next >
Re: [opensuse] cannot reach wireless printer
On 11/17/2014 05:24 AM, Benjamin wrote:

Thanks for information!

How did you check and solve the issue? (I donĀ“t really know much about
routing!)

Best, Benjamin.

Ps Anton: Sorry for sending the mail directly to your private email! Was
a mistake!

Granted.

It was not a routing problem I could see an easy solution for as the
wife router was not very capable. I have a backbone switch and all
other devices hang off that, the printer, desktop, storage, mail hub,
VOIP interface and the wifi that I tried printing from.

That backbone is 192.168.2.x
The wifi network is on 192.168.3.x
But its a low end model I keep meaning to flash with WRT54 but never
seem to get round to, and has routing problems in the other direction
because of NAT. Perhaps something to do with 'discovery'.

Yes the NAT is getting in the way.

We call it a router but in reality its not!


There is a solution involving bypassing the NAT, but with the DHCP
assignment of addresses that might be unstable, so I don't recommend it.
If you want to lock down all the MAC/IP mapping and set up all the
tunnelling then OK. I found an easier way, one that didn't invovle
battling with what the 'router' was and wasn't capable of.

What worked for me, worked instantly and simply was this.

From my tablet I printed to the CUPS driver on my desktop.
For whatever reason that TCP link worked fine even though the link to
the printer didn't. Perhaps something to do with 'discovery'.

You may want to install the "Lets Print" framework and tools.
I found them useful.

--
A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting frowned upon?

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >