Mailinglist Archive: opensuse (1620 mails)

< Previous Next >
Re: [opensuse] Fresh 13.2 install fail - two problems - help please
On Sat, 8 Nov 2014 16:46:20 +0300
Andrei Borzenkov <arvidjaar@xxxxxxxxx> wrote:

Hello Andrei. Thanks for reply.

В Sat, 8 Nov 2014 05:45:29 -0600
listreader <suselist@xxxxxxxxxxxx> пишет:

Howdy...

:~> uname -a
Linux msbmainhp.site 3.11.10-21-desktop #1 SMP PREEMPT Mon Jul 21
15:28:46 UTC 2014 (9a9565d) x86_64 x86_64 x86_64 GNU/Linux

Tried to do an install of 13.2 from DVD and I had a fail. I did a
new/fresh install as I wanted to try the new brtfs/xfs default file
systems.

Problem #1: Install procedure almost completed but failed when it
tried to install the bootloader. The pop-up box message was: "An
error occurred during boot loader installation. Retry boot loader
configuration? Yes No"

I played around with the configuration, changed the bootloader
location from MBR where it had defaulted to and moved it to the
Extended Partition (where my current 13.1 bootloader resides),
tried setting the Active Flag (it was not already set), tried Write
generic Boot Code to MBR (it was not already set), etc., but no go,
same message. So then I just answered NO and the install finished,
system rebooted, and my old 13.1 bootloader appeared. All my
various existing OS boots were there but no 13.2 option.


fdisk -l output would be helpful. Is your btrfs on extended or primary
partition?

13.2 btrfs is on an extended partition, as is 13.2 xfs. Here is fdisk
of the relevant disk (fdisk run from 13.1, not from 13.2). None of the
rest of the disks contain any partitions of 13.2 but I can post those
if it would assist. The working grub2 bootloader from 13.1 is also in
this extended partition / sdb4.


Disk /dev/sdb: 250.1 GB, 250059350016 bytes, 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x04f9e057

Device Boot Start End Blocks Id System
/dev/sdb1 63 40965749 20482843+ 7 HPFS/NTFS/exFAT
/dev/sdb2 40966144 122886143 40960000 7 HPFS/NTFS/exFAT
/dev/sdb3 122886144 206788607 41951232 c W95 FAT32 (LBA)
/dev/sdb4 * 206788608 488396799 140804096 f W95 Ext'd (LBA)
/dev/sdb5 206790656 215175167 4192256 82 Linux swap / Solaris
/dev/sdb6 215177216 257120255 20971520 83 Linux
/dev/sdb7 257122304 341012479 41945088 83 Linux
/dev/sdb8 341014528 429096959 44041216 83 Linux

Drive use: sdb5 is LUKS swap, used by both 13.1 and 13.2, sdb6 is
ext4 / of a 13.1 install, sdb7 is btrfs / of 13.2 install, sdb8 is the
xfs /home of the 13.2 install. There is additional unused/unformatted
space in this extended partition at the end beyond sdb8.



[ 2227.799239] XFS (dm-2): Version 5 superblock detected. This
kernel has EXPERIMENTAL support enabled! Use of these features in
this kernel is at your own risk!
[ 2227.799246] XFS (dm-2): Superblock has unknown incompatible
features (0x1) enabled. Filesystem can not be safely mounted by
this kernel.


I tried "xfs_repair -n" (from 13.1)


As message clearly indicates, filesystem has features that are not
supported by your kernel version. Attempt to "fix" it using downlevel
tools will simply destroy filesystem. You need newer kernel that is
compatible with new filesystem features.

Well "xfs_repair -n" does not make any changes to the filesystem, it is
informational only. I was looking for information on the problem.

I am "looking" at the 13.2 xfs from 13.1 os since I can't boot the
13.2. I would rather not mess with my main/business 13.1 install by
changing kernels at this time. When I am satisfied that the 13.2 is
usable, I will move the data from existing ext4 /home to the new
xfs /home. I do not intend to try to access the xfs drive from any
older OSes, once 13.2 is proven functional.

Thank you.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups