Mailinglist Archive: opensuse (1620 mails)

< Previous Next >
[opensuse] Fresh 13.2 install fail - two problems - help please
Howdy...

:~> uname -a
Linux msbmainhp.site 3.11.10-21-desktop #1 SMP PREEMPT Mon Jul 21
15:28:46 UTC 2014 (9a9565d) x86_64 x86_64 x86_64 GNU/Linux

Tried to do an install of 13.2 from DVD and I had a fail. I did a
new/fresh install as I wanted to try the new brtfs/xfs default file
systems.

Problem #1: Install procedure almost completed but failed when it tried
to install the bootloader. The pop-up box message was: "An error
occurred during boot loader installation. Retry boot loader
configuration? Yes No"

I played around with the configuration, changed the bootloader location
from MBR where it had defaulted to and moved it to the Extended
Partition (where my current 13.1 bootloader resides), tried setting the
Active Flag (it was not already set), tried Write generic Boot Code to
MBR (it was not already set), etc., but no go, same message. So then I
just answered NO and the install finished, system rebooted, and my old
13.1 bootloader appeared. All my various existing OS boots were there
but no 13.2 option.

Problem #2: I booted into 13.1 and looked at the new 13.2 brtfs and xfs
partitions. The brtfs looks fine, or at least I can browse what's in
there. The xfs partition, though, appears broken. I had LUKS
encrypted it during the install/format process but when I try to mount
I get the familiar bad old message about:

"Error mounting /dev/dm-2 at /run/media/(..snip..): Command-line
`mount -t "xfs" -o "uhelper=udisks2,nodev,nosuid" "/dev/dm-2"
"/run/media/(..snip..)"' exited with non-zero exit status 32: mount:
wrong fs type, bad option, bad superblock
on /dev/mapper/luks-5fd1dd43-e7fc-(..snip..), missing codepage or
helper program, or other error"

dmesg shows this additional interesting info:

[ 2227.799239] XFS (dm-2): Version 5 superblock detected. This kernel
has EXPERIMENTAL support enabled! Use of these features in this kernel
is at your own risk!
[ 2227.799246] XFS (dm-2): Superblock has unknown incompatible features
(0x1) enabled. Filesystem can not be safely mounted by this kernel.


I tried "xfs_repair -n" (from 13.1) on all 3 possiblities: the normal
device (/dev/sdb8), the dm device number shown in the above message
(dm-2), and the mapper device also in the above message
(/dev/mapper/luks-5fd1dd43-e7fc-(..snip..) but it just goes off hunting
endlessly for an alternate superblock.

Any ideas, anyone? Keep it simple as I'm just a simple user. Thanks
in advance!

Ralph

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >