Mailinglist Archive: opensuse (982 mails)

< Previous Next >
[opensuse] Re: etckeeper-zypp-plugin broken in 1.13-7.1.x86_64?
Hi all,
I knew the existence of devel:tools:scm/etckeeper by Martin's email.
I can not yet understand relations devel:tools:scm and utilities.
Please teach me the relations of them.

Should I request a bugowner role for devel:tools:scm/etckeeper?


Which ML should I choose for this kind of question?


2014-09-21 0:19 GMT+09:00 1xx <itsango@xxxxxxxxx>:
Hi Martin,

I knew the existence of devel:tools:scm/etckeeper by your email.
I installed devel:tools:scm/etckeeper to openSUSE13.1.
But I could not reproduce your issue.
The devel:tools:scm/etckeeper seems same as utilities/etckeeper.
And etckeeper-zypp-plugin s are same too.

I thought about 2 possibility.

1) Did you config git ?

git config --global user.name 'YOUR Name'
git config --global user.email 'your-email@xxxxxxxxxxx'
sudo cp -i ~/.gitconfig ~root/
sudo etckeeper init

2) Your etckeeper-zypp-plugin did timeout.

The etckeeper-zypp-plugin has a timeout problem now.

http://lists.opensuse.org/opensuse-factory/2014-09/msg00223.html
http://lists.opensuse.org/opensuse/2014-09/msg00256.html

Please check your ZYpp's logs.
(/var/log/zypper.log or /var/log/YaST2/y2log ...)

And I already wrote a patch.
https://build.opensuse.org/package/view_file/devel:tools:scm/etckeeper/etckeeper-avoid-packagelist.patch?expand=1
(This patch sent to upstream, but not accept yet.
https://github.com/joeyh/etckeeper/pull/17 )

Please set AVOID_PACKAGELIST=1 in /etc/etckeeper/etckeeper.conf.
(Please see manual of etckeeper(1).)


By the way,
if you found a problem,
I think that you should tell it to many people.
(eg. ML or Bugzilla.)
So I sent this mail to you and opensuse ML.

2014-09-20 19:18 GMT+09:00 Martin Schröder <martin@xxxxxxxxxx>:
Hi,
you seem to provide the etckeeper-packages for OpenSUSE. I just
noticed a bug (and I'd used the bugtracker, but there is doesn't seem
to be a bugowner etc. for devel.tools.scm) in etckeeper-zypp-plugin in
devel:tools:scm

The problem is: I have installed etckeeper* on two machines: On one
machine the zypp-plugin works, on the other it doesn't (etckeeper is
not called automatically).

The difference: The working version is
etckeeper-zypp-plugin-1.13-1.1.x86_64 from utilities / openSUSE_13.1
the broken version is
etckeeper-zypp-plugin-1.13-7.1.x86_64 from devel:tools:scm / openSUSE_13.1

Can you please check on your side or forward this to somone who can
fix it?

Thanks in advance
Martin

--
1xx <ItSANgo@xxxxxxxxx> <https://twitter.com/ItSANgo>
Mitsutoshi NAKANO <bkbin005@xxxxxxxxxxxxxxx>
<http://d.hatena.ne.jp/Itisango/>
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
References