Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] we don't need no stinkin' dbus...(was Re: progs failing due dbus dependency additions;)
On 2014-03-30 03:34, Linda Walsh wrote:
Carlos E. R. wrote:


So on Telcontar, you have only the DBUS_SESSION_BUS_ADDRESS set,
but when you login, you don't get anything passwd..

Right.

That's a laptop without gnome nor kde installed, because it is old and I
use LXDE. It has some gtk and qt libraries, as required by dependencies
by other packages - like meld, the qt flavour of yast, gkrellm...
----
That meaning 'AmonLack.valinor?

Yes.




An this my relatively modern laptop, with both gnome and kde installed,
I think. Gnome is installed, I tried it recently. KDE I don't remember:

·······························
cer@Telcontar:~> ssh -X cer@minas-tirith.valinor
Password:
Last login: Sat Mar 29 22:22:22 2014 from elessar.valinor
Have a lot of fun...
cer@minas-tirith:~> echo $DBUS_SESSION_BUS_{ADDRESS,{P,WINDOW}ID}$'\n'
-----

I.e minas-tirith is a newer laptop you are logging into?

Yep.

(sounds a bit topsy turvy -- i.e. normally one logs in from laptops to
a server, but you are loggin from ??something to 2 different laptops --
assume
for testing?

That's right :-)

AmonLanc is an old 32 bit laptop (Pentium 4 at 2.80GHz) I use as a small
low power server, used 24/7 when needed. It is sitting with the bottom
cover removed, over a laptop cooling fan. I got the laptop free, the
owner did not want it, too old for recent Windows, he said. It has 500MB
RAM and a 40 GB internal disk only, but new (the original was beyond
repair), and a big external disk via USB. At the time (early 2000s?) it
must have been a real expensive laptop, a beauty. No wifi, though.


minas-tirith is my "real" laptop; when at home I do not use it, but I do
maintenance on it via ssh from the big desktop machine. The keyboard of
the desktop is much better, and the sitting position is more
comfortable. And I also use it for network tests, like now.

I also double boot it in Windows when needed, but then it is called
Minas-Morgul ;-)


A bit of chit-chat :-)


cer@minas-tirith:~>
·······························++- On both machines meld works
remotely. Both have Intel graphics.
---
AFAIK, meld doesn't try to use 3D graphics, so that shouldn't
matter... what's happening is meld on the remote machine is trying
to contact or register with the session manager of the "you" who is
logging into the machine (at least that what it appears to be doing
in my situation.

Yes.




In my case, I have:
law.Bliss> echo $DBUS_SESSION_BUS_{ADDRESS,{P,WINDOW}ID}$'\n'
tcp:host=Athenae.hs.tlinx.org,port=47000,guid=94e7aeae46abdf95e9562eea53362166


Curious, mine says "unix:abstract".
----
unix:abstrict is "sorta" the default. The above is partly from
/etc/dbus-1/session.conf -- where you specify the address for it to listen
on. Since I want Athenae to hear Ishtar's request, I setup a tcp
host+port for it to connect to -- that's what the 'conversation' I looked
at with Wireshark was going to/from.


I've never tried to configure dbus.


But it will not work that way, you need -X or -Y.
----
Those -X is enabled in my /etc/ssh/sshd_config file... as it's
something I always want.

Ahh...

Try it on the command line, just in case :-?




In my case, I do not have a dbus on that session, so meld does not try.
---
On which sess...oooo....*blink*....OOOOOO....

so meld doesn't need a session to run. *lightbulb*

ARG!... I had read the manpage for dbus and it told me to put
code in my bashrc to have it set...

So for this util it doesn't need setting!


Oh. Glad you found it... I'm too sleepy, I don't understand a word :-)


But progress was had and there was much rejoicing in the land!... ;-)


Good!


Off to bed.

Argh! Tonight it is time savings change. The night is one hour shorter.
The computer clock says it is 4:30 AM, my body says it is 3:30 AM.

I hate time change. My body suffers, my digestion suffers, I don't save
a penny - despite what politicians say - and I have to go round
adjusting clocks. I hate it!

--
Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 "Bottle" at Telcontar)

< Previous Next >