Mailinglist Archive: opensuse (929 mails)

< Previous Next >
[opensuse] problem with ROOT from openSUSE repositories

We have some folks here at NASA Langley that want to
start using ROOT, so I have installed it on some of our
Linux machines from the openSUSE Science repositories.
We have version 5.34.17 installed. The installation
seems to have completed successfully, but we are having
problems running some of the examples in the documentation,
as below:

% root
* *
* W E L C O M E to R O O T *
* *
* Version 5.34/17 24 February 2014 *
* *
* You are welcome to visit our Web site *
* *
* *

ROOT 5.34/17 (heads/v5-34-00-patches@v5-34-15-60-gba875ed, Mar 07 2014,
11:10:00 on linuxx8664gcc)

CINT/ROOT C/C++ Interpreter version 5.18.00, July 2, 2010
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0] fa1 = new TF1("fa1","sin(x)/x",0,10);
Error: Symbol TF1 is not defined in current scope (tmpfile):1:
Error: type TF1 not defined FILE:(tmpfile) LINE:1
Warning: Automatic variable fa1 is allocated (tmpfile):1:
Error: Undeclared variable fa1 (tmpfile):1:
*** Interpreter error recovered ***
root [1] exit()
(const int)0

I have tried searching the web for the solution to this problem,
but I have not come up with anything useful so far.

Since I installed this software from RPMs, I did not configure it
myself, so I am not sure what environmental variables need to be set.
I have tried setting ROOTSYS to /usr/bin, which is where the RPM
puts the 'root' executable, and I am guessing that LD_LIBRARY_PATH
should include /usr/lib64/root/5.34/ which seems to be where the
RPM put the libraries, but so far, I have not gotten past the above

Is anyone else out there using the openSUSE Science repository
version of root? Any suggestions?

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups