Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] Install on RAID 1 with local disk and iscsi disk
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Wed, 26 Mar 2014 16:03:39 +0100
  • Message-id: <lguq8n$s3t$1@saturn.local.net>
Andrey Borzenkov wrote:

On Wed, Mar 26, 2014 at 5:36 PM, Per Jessen <per@xxxxxxxxxxxx> wrote:
Paul Neuwirth wrote:

On Mar 13 2014 11:13, Paul Neuwirth wrote:

Hallo,
as mentioned in another thread, i was going to install opensuse
13.1 64bit on several computers with root on a raid 1 containing a
local disk's partition and an iscsi device.
Unexpectedly installation using yast went very smooth, even initrd
was build with suppoirt of iscsi and md (not so installing with
nfsroot). But after reboot all machines stopped with following
message:

EXT4-fs (md0): unable to read superblock

network, iscsi and md initiated correctly..

i tried to install again, and it successfully boots. But with a
degraded RAID, because network and iscsi is startet after md...
how to get a correct initrd? editing manually to set the right
order? thanks for help

Start by making sure your iscsi device has startup=onboot, that
should bring it up early enough.


If I understand the problem correctly, this all happens in initrd?

Hmm, he did say it was root, so yes, it has to be in the initrd. Paul,
you may have to rebuild the initrd to get the iscsi setup copied in.


--
Per Jessen, Zürich (7.4°C)
http://www.dns24.ch/ - free dynamic DNS, made in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups