Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] GUI YaST button does not work, fail to start CLI YaST
On Fri, 21 Mar 2014 18:49:59 +0800
杨国鑫 杨国鑫 wrote:

Hi! I'm a new foreigner and there is some thing wrong on mine
laptop. I don't know what should I do next to fix it.
I can run the YaST by GUI, but there is no more action when I
click on the buttons.
The followings are what had happened under the CLI.

sudo /usr/sbin/yast
sudo /sbin/yast
sudo /sbin/yast2
sudo /usr/sbin/yast2
or by su
yast
/usr/sbin/yast
/sbin/yast
Each just finished and nothing happened.

kdesu /sbin/yast
nothing happened after input the password

kdesu /sbin/yast2
Start the YaST but as same as the GUI one.

By su
yast2
/usr/sbin/yast2
/sbin/yast2
yast --qt
Just give me this
"Qt Warning - invalid keysym: dead_actute"
libGL error: dlopen /usr/lib64/dri/updates/i965_dri.so failed
(/usr/lib64/dri/updates/i965_dri.so: cannot open shared object
file: No such file or directory)
/*I have installed "libgl1-mesa-dri"*/

openSUSE 13.1
X.Org X Server 1.15.0
KDE Platform Version 4.12.2

If anything in this mail is wrong or what can I do next please just
tell me. Thanks a lot!


2014-03-22 6:19 GMT+08:00 Carl Hartung <opensuse@xxxxxxxxxxxxx>:

Hi Aether (I'm guessing your name, sorry!) Have you tried running
it in ncurses mode? Switch to a text console (e.g. CTl+Alt+F1) then
log in as superuser and invoke 'yast'. When done, switch back to
your session (Ctl+Alt+F7).

hth & regards,

Carl

On Sat, 22 Mar 2014 11:14:58 +0800
杨国鑫 杨国鑫 wrote:

ya, name is fine.
I have tried as the following:
in tty1 as su
yast
yast2
yast --ncurses
yast2 --ncurses
None of them gave more information, no yast, no warning, just finished
and I can invoke the next command as usual

It's better to keep the discussion on the list, Aether. Also, the
convention here is to avoid 'top posting'

Are you seeing anything helpful in /var/log/messages?

What does 'ps ax | grep yast' yield?
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
References