Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] printer suddenly disappears ??
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Thu, 13 Mar 2014 09:52:19 +0100
  • Message-id: <lfrrke$9t5$1@saturn.local.net>
Per Jessen wrote:

Billie Walsh wrote:

On 03/12/2014 07:20 AM, Per Jessen wrote:
Billie Walsh wrote:

On 03/12/2014 05:43 AM, Per Jessen wrote:
Per Jessen wrote:

Marcus Meissner wrote:

On Wed, Mar 12, 2014 at 11:26:34AM +0100, Per Jessen wrote:
I was printing some stuff from okular just now, when my
printers suddenly disappeared and I was left with "print to
pdf" or "print to
postcript" only. Same thing in firefox. I restarted cupsd
client and server, and I've checked that the printers are being
broadcast.

I guess I could restarting the machine too, but what happened
to my printers??
Was the cups update we released yesterday installed in the
background?
No, I haven't updated this machine for a week or so.

Did it repopulate the list after some time?
No, I waited around for long enough while I was trying to figure
where
the printer had gone. Looking at other systems, they have no
problems finding the printers :-)
"lpstat -a" on the faulty system shows nothing, on others:

lpstat -a
BESR-printer accepting requests since Sat 01 Feb 2014 13:21:44 CET
Kyocera accepting requests since Sat 01 Feb 2014 13:21:42 CET
Kyocera2 accepting requests since Sat 01 Feb 2014 13:21:43 CET

I've had issues with a network printer that for any reason gets a
new address on the network at odd times [ power flick, or just a
network fart ]. It supposedly always gets the same address
but.............. I have to go into cups and reconnect the "new"
printer.
That's not the case here - a) the printers have static DHCP
allocations and b) the printers work on other systems.

Question - other than rebooting, how would I "re-connect" these
printers
to the client? It seems a bit extreme having to reboot to
re-acquire the printers :-)


For whatever reason it is only my Linux installations that have this
issue. The other halfs Windows computers never have the issue.

I just open cups and reinstall the printer .

Seems superfluous when every other system is working except this one.
I think I'll revert to the Windows solution and reboot it. :-)

Which didn't help much either ... very weird. Am now applying latest
upgrades.



--
Per Jessen, Zürich (8.1°C)
http://www.dns24.ch/ - your free DNS host, made in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups