Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] zypper patch conflicts
On Wed, Mar 12, 2014 at 11:55:34AM +0100, Per Jessen wrote:
Following the recent suggestion wrt using "zypper patch", I thought I
would try it out (having previously only ever used "zypper up" for
updating) - and got the following conflicts:

# zypper patch
Loading repository data...
Reading installed packages...
Resolving package dependencies...
2 Problems:
Problem: patch:openSUSE-2013-956-1.noarch conflicts with
libksane0-debuginfo.x86_64 < 4.11.3-28.1 provided by
libksane0-debuginfo-4.11.2-1.1.x86_64
Problem: patch:openSUSE-2014-79-1.noarch conflicts with
libqt4-debuginfo.x86_64 < 4.8.5-5.9.2 provided by
libqt4-debuginfo-4.8.5-5.6.1.x86_64

Problem: patch:openSUSE-2013-956-1.noarch conflicts with
libksane0-debuginfo.x86_64 < 4.11.3-28.1 provided by
libksane0-debuginfo-4.11.2-1.1.x86_64
Solution 1: Following actions will be done:
do not install patch:openSUSE-2013-956-1.noarch
do not install patch:openSUSE-2014-50-1.noarch
do not install patch:openSUSE-2014-102-1.noarch
Solution 2: deinstallation of libksane0-debuginfo-4.11.2-1.1.x86_64

Seems like you don't have the "debug" update repo enabled, so the
debuginfo packages cannot be updated.

If you don't want the debuginfo packages I would just deinstall them,
i.e. take solution 2...

Cheers,
Michael.

--
Michael Schroeder mls@xxxxxxx
SUSE LINUX Products GmbH, GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References