Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] uefi boot on asus 1225B with only openSUSE
В Sat, 08 Mar 2014 19:37:45 +0100
jdd <jdd@xxxxxxxxx> пишет:

Hello,

some friend of me asked me to install ubuntu on his asus 1225b computer,
wipping all trace of windows.

So I inserted the unbuntu 13.04 disk, installed without problem... and
couldn't boot it, error "no system found".


Which likely means you are attempting legacy boot, not UEFI boot.

This is uefi bios, gpt disk.


Most (if not all) UEFI systems offer fallback to legacy booting using
BIOS interface. In this case it would still load MBR (which exists
on GPT) and if it has legacy boot code, this boot code would look for
active partition which likely does not exist. For all I can tell
this is the only reason for "no operating system found" message.

So I inserted the openSUSE 13.1 dvd... and... same punishment!!


Which again hints that you probably have fallen back to legacy boot
with HDD - DVD boot order. As long as you did not have anything
installed you got booting from DVD; as soon as HDD got valid MBR,
system always tries to boot from it.

Check your system settings, there is little that can be done on
openSUSE side.

I tried all what passed in my mind: verifying /boot/EFI partition was mounted
(it was), trying to set a boot flag (not available in efi/gpt system), even
trying to add manually efi system files ("Windows Boot Manager.efi" or
"Shellx64.efi" as the bios seemed to ask for.. nope. Even tried ELILO without
more success.

I now try to install with standard MBR and grub2 (non efi), and hope to
succeed.

but I would really like to install with efi/gpt system, let only for the
record :-))

any idea?

thanks
jdd
(I wonder if an double boot system would have worked, any people testing
thies
on this pretty common computer?)

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References