Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Printing problem : firewall ?
op 14-01-14 20:20, John Andersen schreef:
On 1/14/2014 3:33 AM, Koenraad Lelong wrote:
On the laptop of my daughter it's not possible to print to a CUPS-printer on a
server without disabling the firewall of the laptop.

First I had the wireless lan in the external zone, and defined exceptions for
IPP in the advanced setup, both TCP and UDP. Did not work.
Then I modified the WiFi interface to the internal zone, and checked the
'protect firewall from internal zone'

Wait, what?!

If you can print by disabling the firewall on the LAPTOP, then why are you
dicking around with
your network structure?

Clearly the problem is in the latptop.

Maybe you should tell us a bit about the laptop OS and what ever OS is used for
your Cups server?

Its possible the laptop is going direct, via Jet-Direct (port 9100), and
ignoring your cups server
when you disable the firewall laptop.
Its also possible your cups server is not serving your local net, but only
itself.

In any event, If the problem is solved by simply disabling the firewall on her
laptop
then the problem is not the structure of the network.


Hi,

Who said anything about the structure of the network ?
Like I said in my first mail, I'm trying to print to a CUPS-server. That means the printer is defined on the server. That server sends broadcast messages to announce its printers. The clients, in this case the laptop, pick up that announcement and give you a choice of the printers installed on the server. No need to install any drivers on the client. That's why I love CUPS.
In my case somehow the firewall refuses to let those broadcasts through when told to (open port IPP=631). So there is definitely something wrong on the laptop, but everything points to the firewall.

Now I'm writing this, my network is IPV6 enabled. Is Yast/Susefirewall opening the ports for IPV6 ? Maybe the server only announces on IPV6. I'll have to sniff.

B.T.W. I have three laptops that behave like this, two running OS12.3 with KDE4, the third has LXDE I think, it's a netbook. But of those three I only investigated the one I reported about.
FWIW, the CUPS-server is Ubuntu 10.04.

And my own laptop does not have those problems, but I run shorewall for ipv4 and ipv6.

Anyway,

thanks for your response.

Koenraad

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups