Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] does anyone have gallery2 on 13.1 running?
On 01/08/2014 04:05 AM, jdd wrote:
Le 08/01/2014 10:44, David C. Rankin a écrit :


The photo-mgmt.php page was one I did back with 11.0. So if we find things
that need to be added or changed, let me know.

I myself use piwigo, which is a similar application

http://dodin.info/piwigo/index.php

no problem with 12.3, but as I want to use the evergreen 13.1 version, I'm
interested about php eventual problems.

there is a thread running on the php subject on the mailing list of pmwiki, an
other of the applications I use

http://www.pmichaud.com/pipermail/pmwiki-users/2014-January/061924.html

it's a bit difficult for me to understand, but may be you can find infos there

jdd


I looked and I will have to look more. the piwigo page makes just general
reference to problems due to deprecated php features as of 5.5. [1] What I ran
into were Fatal errors like:

[Fri Dec 13 18:38:38 2013] [error] [client 192.168.6.102] PHP Fatal error: Class
'Smarty' not found in /srv/http/avantfax/includes/classes.php on line 30

This related to php class include routines. For some reason new php5 causes
older class inclusion routines not to work in Avantfax.

Thankfully, on my server that I have not upgraded to php 5.5, gallery2 (ver 2.3)
still works well with php 5.4.5-1.


-footnotes-

[1] (I don't think 'deprecated' is the correct word, more correctly 'new/changed
features that render old code broken')

--
David C. Rankin, J.D.,P.E.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >