Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Obscure http -> https redirection in Firefox

On 14-01-08 11:01 AM, Stefan Gofferje wrote:
Hi,

I'm experiencing some weird redirection with Firefox 26 on OS 12.3...

On my home server I have 2 different virtual http servers, one for http
and one for https.

I use the http host mainly for all kinds of unimportant stuff, like
making screenshots available to my ISP support and stuff. Behind the
https host lies my "intranet" with webmailer and other stuff.

Now, since shortly, if I enter any arbitrary URL on the http server,
Firefox makes it an https URL which then fails.

For example: http://home.gofferje.net/opensuse/

I can't call this URL from Firefox. Even if I email myself the URL and
click on the URL in Thunderbird, Firefox tries to open
https://home.gofferje.net/opensuse/ which the fails.
It is weirder than you suspect. I just tried your URL, above, in both Firefox 24 on Windows 7, and Firefox 26 on Ubuntu 12.04 (haven't had a chance to check using Firefox on OpenSuse 13.1, yet), and it worked fine, without any redirection. On my Ubuntu box, I opened Firefox by clicking on your link in Thunderbird (which I have installed only on my Ubuntu box).

So, then, how is it that when you try it, you get redirected to make the request over HTTPS and I do not? That is weird indeed. I can see no directive in configuring apache that would do that: if the rewrite rules are set to redirect any given URL or all of them, from HTTP to HTTPS, then it would do so for all visitors. Right? (or perhaps one of the many sysadmins, who know a lot more about configuring apache than do I, know of a way to do it through creative use of a set of directives, but that is something I'd be interested in only if and when I figured out how to use client side certificates to control the content displayed to users - but tht is a digression worthy of a separate thread).

With Konqueror, all works as it's supposed to.

Is this a bug or yet another Mozilla-"all users are stupid and we must
protect them from their own stupidity"-function?

I do have a bookmark to https://home.gofferje.net/ in my Firefox
bookmarks, but ONLY to the home URL, not to any subdirs or pages. And
that opensuse subdir I just created now for this email...

-S
Sorry, I don't know enough to tell you how to fix this, but I thought you ought to know just how weird your problem is due to the fact I can not reproduce your problem here.

Cheers

Ted
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References