Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Video Regression from 11.1 to 12.3 with Radeon 7000
On 01/07/2014 07:48 PM, Larry Stotler wrote:
I've done a great deal of searching & I can't seem to find a useful solution.

I finally got around to getting my old 11.1 install running on my
Thinkpad A30p with Radeon Mobility 7000. With 12.3, The video
performance is slow, and I can't get MPlayer to play a video at all.
With 11.1, I can play an x264 480p video with no problem. The laptop
has a Tualatin P3/1.2Ghz & 1GB RAM.

I've found all kinds of suggestions, like turning off KMS or creating
an xorg.conf file and changing accelmethod from EXA to XXA. Turning
off DRI made no differnce.

Nothing works. There seems to be a similar regression with uBuntu
from 8.10 to 9.04 as well.

I tried to copy the xorg.conf from 11.1 to 12.3 but it fails to load.

Has anyone managed to get this video chip working properly with newer
versions of oS?

Thanx



Have you tried this repository:
http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/

The Xorg in there is much improved over the one that came with 12.3.

The only oddity i've seen from it is some difficulty loading the binary
blob that comes with the video card upon first boot. This is indicated
by extremely laggy performance when dragging windows when you have
the bling turned on (desltop effects in KDE4.). Only seems to happen
after first boot, and or when there are major updates in that repository.

Simply logging out and back in again fixes that.

You have to allow vendor changes to get that repository to update
your Xorg the first time you use it.

It currently has:
X.Org X Server 1.15.0
Release Date: 2013-12-27

Haven't used Mplayer but Kaffine and VLC work perfectly.



--
Explain again the part about rm -rf /
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References