Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Enabling ssl on apache 2.4
* Cristian Rodríguez <crrodriguez@xxxxxxxxxxxx> [01-01-70 12:34]:
El 04/01/14 17:33, Andre Malin escribió:

janv. 04 15:19:04 port start_apache2[5240]: AH00526: Syntax error on
line 48 of /etc/apache2/ssl-global.conf:
janv. 04 15:19:04 port start_apache2[5240]: SSLSessionCache: 'shmcb'
session cache not supported (known n...b?).


a2enmod socache_shmcb

Anomaly:
I recently replaced my 11.1 server with a new install of 13.1 on a new
drive, somewhat hastily due to activity conflicts. Upon returning from
a lengthy trim, noticed that my apache2 logs were not updating.
Somewhat old-school or just plain old, I issued:
rcapache2 status
and get the systemctl report showing the service loaded, enabled, but
not running ???? I am/was able to access the web server from outside
the local net so this does not make sense, and no logs to read!

Grasping straws I read the systemctl output further and noticed an
error, mod_socache2_shmcb was not loaded. So I ran the command,
a2enmode socache_shmcb. My logs immediately updated.

BUT, my web server was active and publically accessable even thou
systemctl reported it not. I had been successfully accessing it for >3
weeks from afar.

Something is not kosher!

--
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri
http://en.opensuse.org openSUSE Community Member facebook/ptilopteri
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
Registered Linux User #207535 @ http://linuxcounter.net
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >