Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
Re: [opensuse] Toshiba laptop with 12.3 - automatic suspend/resume stopped working after latest updates
  • From: Per Jessen <per@xxxxxxxxxxxx>
  • Date: Sat, 04 Jan 2014 17:22:11 +0100
  • Message-id: <la9cfv$san$1@saturn.local.net>
Jan Ritzerfeld wrote:

Am Samstag, 4. Januar 2014, 14:36:51 schrieb Per Jessen:
[...]
In fact only 2 versions. I tried using 3.7.10-1.16, but this had no
effect, it still doesn't auto-suspend/resume. 3.7.10-1.16 is dated
October 2013, I'm pretty certain this problem appeared later.

Okay. You could try "rpm -qa --last | o" to narrow down the search for
the problematic update by installation time. I do not see any
interesting 12.3 updates in the last weeks from openSUSE. Do you use
the proprietary Nvidia driver?

Nope, it's Intel graphics.

Besides, since 12.3 systemd-logind handles the lid switch. Please
check whether acpid is installed because it will conflict with logind.

Yes, acpid _is_ installed and running.

And check /etc/systemd/logind.conf for any non-commented, active
lines.

There is only the section header "[Login]".

What does "journalctl -u systemd-logind" say after you closed
the lid (and opened it again)?

This is almost certainly me logging in, then closing the lid, then
opening:

Jan 04 15:11:06 toshiba1 systemd-logind[669]: New session 12 of user
per.
Jan 04 15:11:06 toshiba1 systemd-logind[669]: Linked /tmp/.X11-unix/X0
to /run/user/1000/X11-display.
Jan 04 15:16:43 toshiba1 systemd-logind[669]: Lid closed.
Jan 04 15:16:46 toshiba1 systemd-logind[669]: Suspending...
Jan 04 15:30:17 toshiba1 systemd-logind[669]: Lid opened.

What is missing is my closing the lid again ... (and the machine wasn't
suspended either). It looks like logind ceases to detect the lid
change?

I tried stopping acpid too, no noticable effect on the functionality.


--
Per Jessen, Zürich (5.6°C)
http://www.hostsuisse.com/ - dedicated server rental in Switzerland.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >