Mailinglist Archive: opensuse (1420 mails)

< Previous Next >
[opensuse] MySQL and apache2 httpd server weirdness
OK, here is the situation. I have two machines running OpenSuse. The only DVD I have that has OpenSuse is for version 12.3. On the one machine, which had been running Windows 7 (a very nice OS IMHO), the only hard drive failed. As I had no install disks for Windows, I decided to install OpenSuse on it, once I replaced the drive. That went fine, and as OpenSuse 13.1 was out, I used the live install method to upgrade that machine immediately (i.e. before I installed any applications and before I put any data on it (while I had the ISO image for 13.1, none of my DVD writers produced a viable DVD; i.e. each of my DVD writers had a hardware problem). Anyway, that upgrade went fine. Once complete, I installed al of the applications and libraries I normally use. I then tested the installation of the Apache webserver, including especially it's ability to execute my cgi scripts, which are written in Perl. That worked fine. I then tested my installation of MySQL, and that, too worked fine.

On the second machine, it has been running 12.3 for a while; at least since early fall. Alas, when I checked it's ability to run my cgi scripts, it refused to run them: and the information in the error log is especially uninformative. I have been spending an inordinate amount of time reviewing the configuration files, without finding anything awry. Since version 13.1 seemed faster, and since everything related to the two server applications I normally use, worked OOTB on the other machine, I decided to upgrade this machine to 13.1 too.

Now, here is the weird part. On the two machines, precisely the same applications are installed, and the identical suite of perl and apache modules or packages are installed; and the configuration files for apache2 are identical. And yet, my cgi scripts run flawlessly on the first described above and they still fail on the second. And, before you ask, yes, the cgi scripts in question are identical. How is that possible? Equally important is, 'How do I fix the second machine? NB: On the second machine, it is only my cgi perl scripts that are not executed. ALL of my perl scripts that are intended to be executed within bash, or as scheduled tasks, work perfectly.

I do not know if it is a coincidence or not, but MySQL works on the first machine described above, and it worked on 12.3 on the second, but after the upgrade to 13.1, MySQL refuses to start, with the only intelligible thing in the logs related to this is a complaint about having upgraded MySQL from an older version (which seems rather silly). For now, I have put all my databases into MySQL running on my Ubuntu box, but I would like to be able to fix this one OpenSuse box so that both the Apache2 and MySQL servers work on it also.

I'd hazard a guess that to get to the bottom of this, you may need additional information, but you'll need to tell me what, and how to get at it. I don't think my apache2 configuration files would be very useful, as they are identical on the two machines, and all works flawlessly on the one (though, they would be if the same problem existed on both).

How do I proceed to sort this out?

Thanks

Ted

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups