Mailinglist Archive: opensuse (878 mails)

< Previous Next >
Re: [opensuse] oS 12.3 and postfix start at boot
В Mon, 30 Sep 2013 12:28:32 +0200
Roger Oberholtzer <roger@xxxxxx> пишет:

On Monday, September 30, 2013 10:59:52 AM Per Jessen wrote:
Roger Oberholtzer wrote:
I have a rather standard oS 12.3 machine. When I reboot, postfix never
starts. I see:

# rcpostfix status

Checking for service Postfix: dead
postfix.service - Postfix Mail Transport Agent

Loaded: loaded (/usr/lib/systemd/system/postfix.service;
enabled) Active: inactive (dead)
CGroup: name=systemd:/system/postfix.service

Sep 30 10:47:29 acme systemd[1]: Dependency failed for Postfix Mail
Transport Agent.

I can immediately restart it and it starts fine. So whatever the
dependency is has been resolved by the time I log in. How can I find
out which dependency failed?

Probably not of much help, but I have a brand new 12.3 system, postfix
works fine here. I don't know how to figure out which dependency it
was that failed - systemd really ought to log it. Maybe try enabling
systemd debugging:

https://en.opensuse.org/SDB:Systemd#Getting_debug_from_systemd

I see this in /var/log/messages:

systemd[1]: Failed to mount /media/mma-sql-1/data3.
systemd[1]: Dependency failed for Remote File Systems.
systemd[1]: Dependency failed for Postfix Mail Transport Agent.
systemd[1]: Job postfix.service/start failed with result 'dependency'.
systemd[1]: Job remote-fs.target/start failed with result 'dependency'.
systemd[1]: Unit media-mma\x2dsql\x2d1-data3.mount entered failed state
systemd[1]: media-mma\x2dsql\x2d1-data6.mount mount process exited,
code=exited status=32
systemd[1]: Failed to mount /media/mma-sql-1/data6.
systemd[1]: Unit media-mma\x2dsql\x2d1-data6.mount entered failed state
systemd[1]: media-mma\x2dsql\x2d1-data4.mount mount process exited,
code=exited status=32
systemd[1]: Failed to mount /media/mma-sql-1/data4.
systemd[1]: Unit media-mma\x2dsql\x2d1-data4.mount entered failed state
systemd[1]: media-mma\x2dsql\x2d1-data2.mount mount process exited,
code=exited status=32
systemd[1]: Failed to mount /media/mma-sql-1/data2.
systemd[1]: Unit media-mma\x2dsql\x2d1-data2.mount entered failed state
systemd[1]: media-mma\x2dsql\x2d1-rst_data.mount mount process exited,
code=exited status=32
systemd[1]: Failed to mount /media/mma-sql-1/rst_data.
systemd[1]: Unit media-mma\x2dsql\x2d1-rst_data.mount entered failed state

Looks like mounting some remote file systems is involved. These file systems
do
get mounted by the time I log in. So they are properly specified in
/etc/fstab.


You could start with showing your /etc/fstab and explaining what these
devices are and why you are using such a strange mount point location
which is reserved for removable media management.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >