Mailinglist Archive: opensuse (878 mails)

< Previous Next >
Re: [opensuse] No usb automount in 12.3
В Mon, 30 Sep 2013 14:26:02 +0200
Marcus Meissner <meissner@xxxxxxx> пишет:

On Mon, Sep 30, 2013 at 08:14:02AM -0400, Anton Aylward wrote:
Andrey Borzenkov said the following on 09/29/2013 10:17 PM:

Or do you mean when I do the modprobe?

Yes, when you use modprobe:

[174437.785824] Initializing USB Mass Storage driver...
[174437.785902] usbcore: registered new interface driver usb-storage
[174437.785904] USB Mass Storage support registered.

I certainly don't get that with -desktop!
Allthough modprobe returns, a i pointed out earlier, 0, ther seems no
actual action; nothing in the log files and noting reported by


Once again, I get


MainBox:/var/log # modprobe usb-storage
MainBox:/var/log # echo $?
0
MainBox:/var/log #

with nothing reported in the system logs and usb-storage not reorted
present by 'lsmod'. In fact 'lsmod|grep usb' shows nothing.

and on device insertion I get

Sep 30 07:53:43 MainBox kernel: [ 983.803737] usb 1-8: USB disconnect,
device number 6
Sep 30 07:53:47 MainBox kernel: [ 988.130036] usb 1-8: new high-speed USB
device number 7 using ehci_hcd
Sep 30 07:53:47 MainBox kernel: [ 988.252449] usb 1-8: New USB device
found, idVendor=058f, idProduct=6387
Sep 30 07:53:47 MainBox kernel: [ 988.252455] usb 1-8: New USB device
strings: Mfr=1, Product=2, SerialNumber=3
Sep 30 07:53:47 MainBox kernel: [ 988.252458] usb 1-8: Product: Mass
Storage
Sep 30 07:53:47 MainBox kernel: [ 988.252461] usb 1-8: Manufacturer:
Generic
Sep 30 07:53:47 MainBox kernel: [ 988.252464] usb 1-8: SerialNumber:
986D9FD4
Sep 30 07:53:47 MainBox mtp-probe: checking bus 1, device 7:
"/sys/devices/pci0000:00/0000:00:02.1/usb1/1-8"
Sep 30 07:53:47 MainBox mtp-probe: bus: 1, device: 7 was not an MTP device

I do know USB works. I've been downloading from my camera using digikam
and gphotofs.

Once again, this is 12.3 with 3.7.10-1.16-desktop

I think your device is just not detected as mass storage device.


The real question is - why usb-storage is not present in module list
after being apparently successfully loaded.

can you run "lsusb -v" with your device attached and post the device part
here?

Ciao, Marcus

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups