Mailinglist Archive: opensuse (878 mails)

< Previous Next >
Re: [opensuse] No usb automount in 12.3
В Sun, 29 Sep 2013 11:31:09 -0400
Anton Aylward <opensuse@xxxxxxxxxxxxxxxx> пишет:

Carlos E. R. said the following on 09/29/2013 10:53 AM:
On Sunday, 2013-09-29 at 10:28 -0400, Anton Aylward wrote:


I got that error yesterday with my samsung camera.

My Fuji camera 'works just fine'.
I plug it in and turn it on and get a popup offering to download with
gwewnview or digikam.
Actually I ignore that and use gphotofs.

Not all cameras appear as mass storage devices.

In absolute terms cameras implement a comms protocol where as USB sticks
*are* storage devices.


I would say you try other sticks.

I just worked you half a dozen, different vendors.
All the same.

I also tried running 'usbview' and get an interesting message:

Cannot open the file /proc/bus/usb/devices
Verify you have USB compiled into your kernel
have the USB core modules loaded, and have the
usbdevfs file system mounted.

/proc/bus/usb was removed from kernel more than a year ago:

commit fb28d58b72aa9215b26f1d5478462af394a4d253
Author: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>
Date: Wed Apr 25 17:15:29 2012 -0700


This option has been deprecated for many years now, and no userspace
tools use it anymore, so it should be safe to finally remove it.

As I mentioned, modprobe of usbcore and usb_storage don't seem to take.
No errors, just that a subsequent lsmod shows they aren't there.

usbcore is built-in on 12.3. What is your exact command line for

I *DO* have a line in the /etc/fstabe for usbfs and /proc/bus/usb

I'm wondering if this is a Udisk2 or a udev issue?

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups