Mailinglist Archive: opensuse (878 mails)

< Previous Next >
Re: [opensuse] oS 12.3 - why the long delay....
On 23/09/13 18:37, Per Jessen wrote:
Rodney Baker wrote:

On Mon, 23 Sep 2013 13:19:10 Basil Chupin wrote:
On 22/09/13 05:35, Andrey Borzenkov wrote:
В Sun, 22 Sep 2013 00:11:03 +1000

Basil Chupin <blchupin@xxxxxxxxxxxx> пишет:
On 21/09/13 23:18, Andrey Borzenkov wrote:
� Sat, 21 Sep 2013 22:53:10 +1000

Basil Chupin <blchupin@xxxxxxxxxxxx> �����:
It is not the question of dependencies. You have single service
that takes this time to start.

The first obvious question - are you using ifup or
NetworkManager.
ifup.
OK, then you can simply test what happens if you manually start
it.

export SYSTEMD_NO_WRAP=1
/etc/init.d/network stop
/etc/init.d/network start

Does it take the same time?
Yep, perhaps a second longer as well.
OK. Check "journalctl -u network.service". It gives you output of
scripts run when networks starts with time stamps. This could
provide enough hints what step takes the most time.

If not, you can stick "set -x" on top of /etc/init.d/network and
look where it stalls.
Here is the output of 'journalctl':

[...snip...]
Sep 23 00:02:03 linux-67gf.site dhcpcd[1461]: eth0: adding default
route via 192.168.1.1 metric 0
Sep 23 00:02:03 linux-67gf.site dhclient[1477]: send_packet6: Cannot
assign requested address
Sep 23 00:02:03 linux-67gf.site dhclient[1477]: dhc6: send_packet6()
sent -1 of 58 bytes
Sep 23 00:02:03 linux-67gf.site dhcpcd[1461]: eth0: Failed to lookup
hostname via DNS: Name or service not known
Sep 23 00:02:20 linux-67gf.site network[576]: eth0 Starting
DHCP4+DHCP6 client. . . . . . . .
Sep 23 00:02:20 linux-67gf.site network[576]: eth0 IP address:
192.168.1.2/24
Sep 23 00:02:20 linux-67gf.site network[576]: eth0 DHCP6
continues in background
Sep 23 00:02:20 linux-67gf.site network[576]: ..doneSetting up
service
network . . . . . . . . . . . . ...done

BC
The timeout is occurring because your DHCP client is looking for an
IPv6 dhcp server and can't find one. This can also cause slow DNS
response times because IP6 names are searched for before IP4 names.

If you're not using IPv6 locally, disable it in network settings (via
YaST) and reboot.
Or just change the network config to only use dhcpv4. No reboot
necessary, except to verify :-)

Sorry Per - changing this requires a reboot. YaST tells me so and I am not about to argue with YaST :-)

BC

--
Using openSUSE 13.1, KDE 4.11.1 & kernel 3.11.1-3 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel Corsair "Vengeance" RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX550Ti 1GB DDR5 GPU



--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups