Mailinglist Archive: opensuse (880 mails)

< Previous Next >
[opensuse] grub2 enigma
Can anyone please provide an answer or suggest some doc. to read (but NOT a manual :-( ) which would provide me with the answer. Searching the web has not really provided an answer. The problem is with grub2.

To begin:

I have 2 HDDs - sda and sdb - both sitting in mobile racks.

I have the following systems installed on these 2 drives:

sda3 openSUSE 12.2

sda5 opensuse 12.3

sda6 Tumbleweed (12.3)

sda7 Ubuntu 13.04

sda8 openSUSE 13.1 Milestone #4

sdb1 Windows #7

In addition I have a separate bootloader which contained/contains grub.cfg which will boot (or did boot) all and any of the above. This bootloader is sitting in sda1 and I mount it manually in /mnt/btldr when required.

I orginally installed 12.2 on sda3 and then installed Windows on sdb1 (to do this Win installation I removed sda from the box and Windows was able to install its bootloader in the MBR for sdb).

After this was done I mounted sda1 - the btldr partition - and ran:

grub2-install --root-directory=/mnt/btldr /dev/sda

followed by

(2) grub2-mkconfig -o /mnt/btldr/boot/grub2/grub.cfg

to populate the grub.cfg in the /btldr/boot/grub2/.

This was working fine for months even after I added 12.3, Tumbleweed, Ubuntu, and Milestone 1, 2, and 3.

However, something went dodgy and now if I boot into 12.2 and run (2) above oS 12.3 on sda5 is not recognised in the btldr; yet running grub2-mkconfig -o /boot/grub2/grub.cfg in 12.2 does see sda5 - but is left out in btldr.

The "reverse" happens if I manage (using smoke and mirrors) to boot into 12.3 and then 12.2 (on sda3) is omitted from btldr when I run (2).

I have used the Ubuntu's Boot Rescue Disk and while the first time I used it (a couple of weeks ago) it recognised all of the systems but when I ran it again earlier tonight it did not recognise 12.3 on sda5.

I really wish I knew what to do to get back to where I was before this dodgy-thing struck and therefore be able to boot into all of the systems I have currently installed.

So if anyone can throw some light on how to overcome this dilemma please advise me.

(The inability to create the correct grub menu by running grub2-mkconfig -o /mnt/btldr/boot/grub2/grub.cfg is preventing the upgrading of new versions of the kernel because I need to boot into level 3 in order to compile the nvidia driver for the new kernel.)

BC

--
Using openSUSE 12.3, KDE 4.11.0 & kernel 3.10.5-1 on a system with-
AMD FX 8-core 3.6/4.2GHz processor
16GB PC14900/1866MHz Quad Channel Corsair "Vengeance" RAM
Gigabyte AMD3+ m/board; Gigabyte nVidia GTX550Ti 1GB DDR5 GPU


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups