Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] Troubles with Nvidia
Hello

Dne St 7. srpna 2013 16:37:23, Werner Flamme napsal(a):
[07.08.2013 15:43] [Vojtěch Zeisek]:
Hello,
thank You for all comments.

Dne St 7. srpna 2013 14:04:40, Werner Flamme napsal(a):
[07.08.2013 13:40] [Vojtěch Zeisek]:
Hi,
I probably do some silly mistake, but I can't manage it to work. I have
NVIDIA GeForce GT630M (2 GB memory, 96 CUDA cores) and I followed
http://en.opensuse.org/SDB:NVIDIA_drivers#The_repository_way to install
original drivers to be able to use full power of the chip.
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core
processor
Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT
630M] (rev a1)

Uh. This is Optimus technology, isn't it? Yes, it is:
<http://www.geforce.com/hardware/notebook-gpus/geforce-gt-630m>. I think
you need to install the butterfly package as well, as it is mentioned in
<https://en.opensuse.org/SDB:NVIDIA_drivers#Easy_way_to_get_NVIDIA_driver
s>. See also <http://bumblebee-project.org/>.

I installed it (version 3 from šumski's repository). I did it over again
with same result (see below). When I installed x11-video-nvidiaG02, it
also installed x11-video-nvidiaG03 and related nvidia-... packages. And
yes, I'm member of video and bubmblebee groups.

OK, did you read
</usr/share/doc/packages/x11-video-nvidiaG03/html/optimus.html> then? Or
any other file in this directory?

Previously not. After reading it, still don't get the point...

BTW, in supportedchips.html in this directory you can see that
x11-video-nvidiaG03 supports the GT630M chip so that you can uninstall
the G02 variants, just to avoid that they fight each other.

Why didn't I stayed with Intel graphics?

I installed (for my G96 [GeForce 9400 GT]):
- nvidia-computeG03-319.32-15.1.x86_64
- nvidia-gfxG03-kmp-desktop-319.32_k3.7.10_1.1-15.1.x86_64
- x11-video-nvidiaG03-319.32-15.1.x86_64
all from http://download.nvidia.com/opensuse/12.3

Now I have only the 03 packages. When I run
# nvidia-debugdump --dumpall
FATAL: Module nvidia not found.
NVIDIA: failed to load the NVIDIA kernel module.
Error: nvmlInit(): Driver Not Loaded
# nvidia-modprobe
FATAL: Module nvidia not found.
# rpm -qa |grep nvidia



nvidia-settings-290.10-1.9.x86_64
nvidia-computeG03-319.32-15.1.x86_64
nvidia-gfxG03-kmp-desktop-319.32_k3.7.10_1.1-15.1.x86_64
x11-video-nvidiaG03-319.32-15.1.x86_64
# rpm -qa |grep bumblebee
bumblebee-2.4.1-4.1.x86_64
I feel lost. :-(

NVRM: loading NVIDIA UNIX x86_64 Kernel Module 319.32 Wed Jun 19
15:51:20
PDT 2013
2013-08-06T08:20:17.400659+02:00 veles kdm[948]: X server died during
startup 2013-08-06T08:20:17.401228+02:00 veles kdm[948]: X server for
display :0 cannot be started, session disabled

This might be because of the dual video chipset in your box. I only
found a russian text about it,
<http://ru.opensuse.org/SDB:NVidia_Optimus>, but no translations.

It has only Nvidia graphic card. BIOS has no setting related to graphic
card.
Pardon? Didn't I read

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core
processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT
630M] (rev a1)

in your first post? There are two graphics controllers, and bumblebee
should allow switching between them.

Hehe... HP's product page lists just the Nvidia as graphic card, so that I
automatically supposed it has only one card. Neither product specifications
mention 2 graphic controllers. Confusing.

Nvidia generates this xorg.conf:
I use nvidia drivers, and I have no xorg.conf. If you work on real
hardware, there are way too many "vmware" and "vbox" entries in this file.

It does't work. This is report of Xorg log:

X.Org X Server 1.13.2
Release Date: 2013-01-24
[ 71.426] X Protocol Version 11, Revision 0
[ 71.426] Build Operating System: openSUSE SUSE LINUX
[ 71.426] Current Operating System: Linux veles.site
3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba)
x86_64
[ 71.426] Kernel command line: BOOT_IMAGE=/vmlinuz-3.7.10-1.16-desktop
root=/dev/mapper/pocitac-koren ro elevator=cfq
[ 71.426] Build Date: 15 July 2013 12:22:00PM
[ 71.426]
[ 71.426] Current version of pixman: 0.28.2
[ 71.426] Before reporting problems, check http://wiki.x.org

to make sure that you have the latest version.

[ 71.427] (==) ModulePath set to
"/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"

[ 71.428] (II) LoadModule: "glamoregl"
[ 71.429] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[ 71.434] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so:
/usr/lib64/xorg/modules/libglamoregl.so: undefined symbol:
_glapi_tls_Context
Hm. On my box, "rpm -qf /usr/lib64/xorg/modules/libglamoregl.so" gives
glamor-0.5-3.1.3.x86_64, directly from openSUSE distro. Do you have
another version? Where does it come from?

I use openSUSE 12.3 64 bit,
rpm -qf /usr/lib64/xorg/modules/libglamoregl.so
glamor-0.5-3.1.3.x86_64
from main OSS repository.

[ 71.440] (II) LoadModule: "nvidia"
[ 71.441] (II) Loading
/usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
[ 71.441] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 71.441] compiled for 4.0.2, module version = 1.0.0
[ 71.441] Module class: X.Org Video Driver
[ 71.441] (II) NVIDIA dlloader X Driver 319.32 Wed Jun 19 14:34:12
PDT
2013
[ 71.441] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 71.441] (--) using VT number 7

[ 71.445] (EE) No devices detected.

Yes, and now we see that the driver does not find any device.

Yes, but why?

I use VirtualBox (if that matters), but I have no idea why there is any
vmware section - I haven't installed it and I'm not going to install it.
I also lost boot splash screen although all packages should be installed.
Well, never mind at all. ;-)

Ahem... are you installing the driver inside a VirtualBox VM? If not,
you can delete all this, and all the VMWare things too. It is there to
give openSUSE some help when started inside a virtual machine, not on a
host that runs VirtualBox or VMWare Player. I suggest you rename
xorg.conf to something that xorg does not look for, like
xorg.conf.nonsense ;-). So xorg's autodetect feature will be startet,
and might become successful.

I installed openSUSE to real HW, HP ENVY dv6 notebook. I also use it as
VirtualBox host. You mean, that xorg.conf should be recreated during startup?
;-)

You might have to run mkinitrd again to have a splash screen fitting to
the detectd X display device. If there is any...

Regards,
Werner
Thank You,
Vojtěch

--
Vojtěch Zeisek

Komunita openSUSE GNU/Linuxu
Community of the openSUSE GNU/Linux

http://www.opensuse.org/
http://trapa.cz/
< Previous Next >
Follow Ups