Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] Gramps update problem (solved)
  • From: "C. Brouerius van Nidek" <constant@xxxxxxxxxxx>
  • Date: Tue, 06 Aug 2013 21:21:40 +0700
  • Message-id: <1949773.zVygxkqf9q@dhcppc0>
On Tuesday, August 06, 2013 08:21:55 AM Patrick Shanahan wrote:
* C. Brouerius van Nidek <constant@xxxxxxxxxxx> [08-06-13 04:06]:
Since short I have started to use Gramps genealogical software. The stable
version 3.4.2-2.1.2 is on offer for 12.3 Tumbleweed. As there is a
completely rewrite of this software developed I found this version
4.0.1-33.1 build by ecsos, found at:

http://download.opensuse.org/repositories/home:/ecsos/openSUSE_Tumbleweed/

I have put this site on the repositories and gave it the lowest number of
all repos.
Since two days I ran into following problem. Zypper dup wants to replace
the 4,0.1 with the 3.4.2.

Strange because the 4.01 has a higher number and the 3.4.2 has a higher
repository number. I do not lock the 4.0.1 because than I would not get
eventual updates.

Hard to say w/o seeing the priorities set for your repos. Perhaps some
python requirement ???

Priority for gramps 4.0.1set to 93 the older gramps priority 97

Solved it for the moment by locking the lang part of Gramps but wonder why
the newer software should find itself replaced by the lower numbered
version.
Solve it better by locking gramps from the provider of 3.4.2. Then zypper
will only update from other providers of which at present there is only
ecsos.

Found that the URL

http://download.opensuse.org/repositories/home:/ecsos/openSUSE_Tumbleweed/

was not refreshing the repros. With the webbrowser the site seemed to work.
Changed to the alternative site

http://ftp5.gwdg.de/pub/opensuse/repositories/home:/ecsos/openSUSE_Tumbleweed/

and everything worked as expected.

--
Linux User 183145 using KDE4 and LXDE on a Pentium IV ,
powered by openSUSE 12.3 (i586) Kernel: 3.10.3-19.gec6c1d9-default
KDE Development Platform: 4.10.5 "release 1"
21:13pm up 5 days 5:40, 4 users, load average: 0.99, 0.82, 0.69

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >