Mailinglist Archive: opensuse (880 mails)

< Previous Next >
Re: [opensuse] Gramps update problem
* C. Brouerius van Nidek <constant@xxxxxxxxxxx> [08-06-13 04:06]:
Since short I have started to use Gramps genealogical software. The stable
version 3.4.2-2.1.2 is on offer for 12.3 Tumbleweed. As there is a completely
rewrite of this software developed I found this version 4.0.1-33.1 build by
ecsos, found at:

http://download.opensuse.org/repositories/home:/ecsos/openSUSE_Tumbleweed/

I have put this site on the repositories and gave it the lowest number of all
repos.
Since two days I ran into following problem. Zypper dup wants to replace the
4,0.1 with the 3.4.2.

Strange because the 4.01 has a higher number and the 3.4.2 has a higher
repository number. I do not lock the 4.0.1 because than I would not get
eventual updates.

Hard to say w/o seeing the priorities set for your repos. Perhaps some
python requirement ???

Solved it for the moment by locking the lang part of Gramps but wonder why
the
newer software should find itself replaced by the lower numbered version.

Solve it better by locking gramps from the provider of 3.4.2. Then zypper
will only update from other providers of which at present there is only
ecsos.

--
(paka)Patrick Shanahan Plainfield, Indiana, USA HOG # US1244711
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org openSUSE Community Member
Registered Linux User #207535 @ http://linuxcounter.net
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >