Mailinglist Archive: opensuse (686 mails)

< Previous Next >
Re: [opensuse] Ruby is not working [SOLVED]
On Wed, 17 Jul 2013 17:22:51 +0200, Togan Muftuoglu <toganm@xxxxxxxxxxxx>
said:


Togan> ~ $ ruby --version

Togan> /usr/bin/ruby: error while loading shared libraries:
Togan> libruby.so.1.8: cannot open shared object file: No such file or
Togan> directory

It turns out to be a packaging issue for those of us coming from 12.1 and
probably earlier releases. Solution is easy

rm /usr/bin/ruby

update-alternatives --auto ruby


--

o .o. o o_ o_ _o _o ,_o o_
<|> `|' (|) )' ),' ` |( ' (, ,( )| '
( ) [ ] [ ] >\ / > < \ /< < \ / >
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
References