Mailinglist Archive: opensuse (686 mails)

< Previous Next >
Re: [opensuse] md stealing disks!
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Thu, 18 Jul 2013 00:39:41 +0200 (CEST)
  • Message-id: <alpine.LNX.2.00.1307172151010.2653@Telcontar.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



On Wednesday, 2013-07-17 at 10:53 -0700, Lew Wolfgang wrote:

Hi Folks,

Here's an odd one. I pulled a "zypper dup" yesterday on
a 12.3 x86-64 without any obvious issues.

But today, I connected a brand new 3.5-in SATA disk to the
system with one of those SATA/USB converters. I do this
all the time and have never had any issues.

So, I "tail -f /var/log/messages" to get the /dev/sdx id
and then run fdisk /dev/sdf, in this case. I create one
Linux partition using the whole disk. No problems noted.

But now, when I run "mkfs.xfs /dev/sdf1" I get this error:

Notice that you could also create the filesystem on the whole disk, no partitions.

What type number did you use for the partition? There is one for raid, if the system sees it, it will automatically try to use md on the partition.

It looks like md is snatching the disk! But I'm not running md,
to the best of my knowledge. A "ps ax |grep -i md" shows:

90 ? S< 0:00 [md]
95 ? SN 0:00 [ksmd]

Is systemd quietly starting md which is then trying to be helpful?
"kill -9 90" doesn't touch the process.

Because it is a kernel thread, not a program. Not killable.


This process of adding/formatting disks has worked for decades before
yesterday's zypper dup. Are other folks seeing this?

It might have other reasons :-)

- -- Cheers,
Carlos E. R.
(from 12.3 x86_64 "Dartmouth" at Telcontar)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)

iEYEARECAAYFAlHnHS0ACgkQtTMYHG2NR9WsWQCglG90pF4Zmp04OzeDSpmspV8r
8wMAniBGNSIae68CcTgiNfH7lKFWrM3+
=cPiG
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References