Mailinglist Archive: opensuse (686 mails)

< Previous Next >
Re: [opensuse] Problem mounting nfs partition on 12.3
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

В Sun, 14 Jul 2013 00:22:48 +0200 (CEST)
"Carlos E. R." <robin.listas@xxxxxxxxxxxxxx> пишет:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Content-ID: <alpine.LNX.2.00.1307140008050.16893@Telcontar.valinor>


On Saturday, 2013-07-13 at 11:47 +0400, Andrey Borzenkov wrote:


В Thu, 11 Jul 2013 15:02:55 +0200 (CEST) "Carlos E. R." <> пишет:
Now I need it to work from the laptop, and it fails.


So what exactly did you change? You say it was working before so you
changed something, right?

Me, nothing.

I upgraded the server system from 12.1 to 12.3, an offline upgrade
procedure. The exports file was not touched.

The client system, the laptop, is still 11.4.


Ah, OK, this is another system, sorry I was confused.
[...]
Did package reach the server at all? Use tcpdump/tshark to verify.

The server firewall logs the package as being allowed, so yes, it does
reach the server.

Did you try to disable firewall on both client and server to be sure it
does not influence it?


Is there some other configuration file for NFSserver where one can specify
which interfaces to listen on?

man 8 nfsd

I see nothing there about a configuration file, or related to my problem.
The word "interface" does not exist.


-H or --host hostname
specify a particular hostname (or address) that NFS requests
will be accepted on. By default, rpc.nfsd will accept NFS
requests on all known network addresses. Note that lockd (which
performs file locking services for NFS) may still accept request
on all known network addresses. This may change in future
releases of the Linux Kernel.



For the record, I solved the problem by forcing the client in the laptop
to use NFS 3 (nfsvers=3).


I was about to suggest it ... :)

I changed the fstab like this:

192.168.1.14:/data/storage_c/repositorios_zypp/
/var/cache/zypp/nfs_packages nfs defaults,noauto,_netdev,nfsvers=3 0 0

And it works, which is a regression, because previously it worked with
nfsvers=4. And it is weird, because two clients using 12.3 can connect
with nfs 4.


It is quite possible that in the past it silently used NFS V3 without
you be aware of it.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)

iEYEARECAAYFAlHiWrEACgkQR6LMutpd94zKXwCgiDg8Xgnz1USb9KCIUhAlKMZD
5SsAn1yvb4fv7ACA5eYrNWULVsoZQkKy
=EH1/
-----END PGP SIGNATURE-----
< Previous Next >
Follow Ups