Mailinglist Archive: opensuse (686 mails)

< Previous Next >
Re: [opensuse] problems with systemctl and teamviewer daemon [SOLVED]
On Monday 01 Jul 2013 18:49:14 Cristian Rodríguez wrote:
El 01/07/13 18:44, Eddie escribió:
However, when I try systemctl start teamviewerd.service I get the No such
file or directly error mentioned above.

Yes, you need to run systemctl daemon-reload before enable and start.,
(it is not automagic, making it magic will introduce race conditions)

Because you suggested that systemctl daemon-reload needed to be run before
enable, I attempted to disable it by running systemctl disable
teamviewerd.service. This produced the following messages:

rm '/etc/systemd/system/teamviewerd.service'
rm '/etc/systemd/system/graphical.target.wants/teamviewerd.service'

When I tried systemctl enable teamviewerd.service (after the daemon-reload) I
got the following error:

systemctl enable teamviewerd.service
Failed to issue method call: No such file or directory

so I tried to recreate the linked files
/etc/systemd/system/teamviewerd.service (that went okay)
but when I tried to recreate
/etc/systemd/system/graphical.target.wants/teamviewerd.service
it failed because the directory "graphical.target.wants" didn't exist.

So having created the directory and then the link file, the systemctl enable
and start commands worked without error.

It all seems to be working. I've concluded that the error was caused by the
non-existent graphical.target.wants/teamviewerd.service link.

Thanks very much for all your help. I really appreciate it.

Eddie
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >