Mailinglist Archive: opensuse (1239 mails)

< Previous Next >
Re: [opensuse] Why does gvim need systemd?
В Sun, 09 Jun 2013 08:15:33 -0700
Linda Walsh <suse@xxxxxxxxx> пишет:

Gvim, among several other suspicious packages has a dependency on
systemd.


It does not.

bor@opensuse:~/src/mdadm> zypper info --requires gvim
...
/bin/sh
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libpthread.so.0()(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libglib-2.0.so.0()(64bit)
libc.so.6(GLIBC_2.7)(64bit)
libgobject-2.0.so.0()(64bit)
libc.so.6(GLIBC_2.15)(64bit)
libX11.so.6()(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.11)(64bit)
libgdk_pixbuf-2.0.so.0()(64bit)
libgtk-x11-2.0.so.0()(64bit)
libgdk-x11-2.0.so.0()(64bit)
libpango-1.0.so.0()(64bit)
libpython2.7.so.1.0()(64bit)
libtinfo.so.5()(64bit)
update-alternatives
libXt.so.6()(64bit)
libSM.so.6()(64bit)
libICE.so.6()(64bit)
libruby1.9.so.1.9()(64bit)
libtcl8.5.so()(64bit)
libacl.so.1()(64bit)
libperl.so()(64bit)
libacl.so.1(ACL_1.0)(64bit)
vim-data
libgpm.so.2()(64bit)
gvim_client
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
perl == 5.16.2
vim-base == 7.3.831
config(gvim) == 7.3.831-1.1.1

Where do you see "systemd" in this list?

Um...why?
It seems to install and work just fine w/o systemd -- so why the
dependency? I've noticed this in other packages as well --
a dependency on systemd has been tossed in with nothing in the
package actually requiring systemd in order to function.

So what's up w/these seemingly inaccurate dependencies?

It seems to me that if someone starts putting fake dependencies
in packages it makes the rpm-dep system a bit pointless.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References